'Other...' permanently on login screen, 10.5.6

Discussion in 'macOS' started by MarcBook, May 11, 2009.

  1. MarcBook macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #1
    Hello all,

    For some unknown reason, the 'Other...' option is now permanently visible on my login screen and I can't seem to get rid of it.

    Since it has the Network symbol as its image, I made sure the option to allow network users to log in was unticked (and it was unticked) in System Prefences (Accounts).

    I read somewhere that the Other... option appears when the root user is activated in Directory Utility, but I had a look and it was disable, as is by default.

    Does anyone know why 'Other...' is listed on my login screen and now to disable it? Although not a serious problem, it's bugging me somewhat.

    Thanks in advance.
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Disable root.
    "Other" appears when root is enabled.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    I found another person with the same issue here. The only solution idea was to enable root, then try to disable it again to see if it takes correctly.
     
  4. MarcBook thread starter macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #4
    I had tried that previously, just tried it again, no difference... :(

    It's definitely not an issue with the root user, I think.

    Thanks for the suggestion, though.
     
  5. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #5
    AFAIR, "Other" doesn't appear unless root is enabled. Is root enabled on your Mac?
     
  6. MarcBook thread starter macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #6
    Hello, yellow. I think you'll find that in the original post I mentioned checking the root user option. It was never turned on and I've tried turning it on and then off to no avail. Other... is still in the login window.

    I've also tried doing a permissions repair, running maintenance scripts and then repeating the root setting and the network users setting. It still won't go away.

    I don't even know what caused it in the first place. :confused:

    Thanks for your replies, though.
     
  7. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #7
    Do this.. enable root, then disable root.
    What about Guest, is guest enabled?
     
  8. MarcBook thread starter macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #8
    Solution Found

    Sorry to bump this thread again, but just in case anyone is reading this and has been experiencing this problem, I managed to be told a solution over on the Apple Discussions website.

    View the solution here
     

Share This Page