Out of application memory on a retina iMac

Discussion in 'iMac' started by nutcaseguy, Jun 2, 2015.

  1. nutcaseguy, Jun 2, 2015
    Last edited: Jun 2, 2015

    nutcaseguy macrumors newbie

    Joined:
    Oct 17, 2011
    #1
    For the past two weeks I have been running out of application memory. I window pops up informing me and pausing some applications. I have 28 GB RAM installed. I checked Activity Monitor and the processes using the most RAM are as follows

    ActivityMonitor.jpg

    When I took this screenshot I did not have any applications running ( from the dock)

    I would appreciate some help, Thanks

    Gordon


    EtreCheck version: 2.2 (132)
    Report generated 6/2/15, 11:37 AM
    Download EtreCheck from http://etresoft.com/etrecheck

    Click the [Click for support] links for help with non-Apple products.
    Click the [Click for details] links for more information about that line.
    Click the [Click to remove] links for help removing adware.

    Hardware Information: ℹ️
    iMac (Retina 5K, 27-inch, Late 2014) (Technical Specifications)
    iMac - model: iMac15,1
    1 4 GHz Intel Core i7 CPU: 4-core
    28 GB RAM Upgradeable
    BANK 0/DIMM0
    8 GB DDR3 1600 MHz ok
    BANK 1/DIMM0
    8 GB DDR3 1600 MHz ok
    BANK 0/DIMM1
    4 GB DDR3 1600 MHz ok
    BANK 1/DIMM1
    8 GB DDR3 1600 MHz ok
    Bluetooth: Good - Handoff/Airdrop2 supported
    Wireless: en1: 802.11 a/b/g/n/ac

    Video Information: ℹ️
    AMD Radeon R9 M295X - VRAM: 4096 MB
    iMac 5120 x 2880
    LED Cinema Display 2048 x 1152

    System Software: ℹ️
    OS X 10.10.3 (14D136) - Time since boot: 3:6:57

    Disk Information: ℹ️
    APPLE SSD SM0512F disk0 : (500.28 GB)
    EFI (disk0s1) <not mounted> : 210 MB
    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB
    Macintosh HD (disk1) / : 499.10 GB (153.12 GB free)
    Core Storage: disk0s2 499.42 GB Online

    USB Information: ℹ️
    VIA Labs, Inc. USB3.0 Hub
    VIA Labs, Inc. USB3.0 Hub
    Seagate Expansion Desk 3 TB
    EFI (disk5s1) <not mounted> : 315 MB
    iTunes Movies Backup (disk5s2) /Volumes/iTunes Movies Backup : 3.00 TB (197.25 GB free)
    Seagate Backup+ Desk 5 TB
    iTunesHDMusic Full Backup (disk4s1) /Volumes/iTunesHDMusic Full Backup : 5.00 TB (1.15 TB free)
    USB 3.0 to eSATA Cable 12 TB
    EFI (disk3s1) <not mounted> : 210 MB
    OWC Mercury Elite Pro Qx2 (disk3s2) /Volumes/OWC Mercury Elite Pro Qx2 : 12.00 TB (4.60 TB free)
    Apple Inc. FaceTime HD Camera (Built-in)
    Apple Inc. BRCM20702 Hub
    Apple Inc. Bluetooth USB Host Controller
    Wadia Wadia USB Audio 2.0
    VIA Labs, Inc. USB2.0 Hub
    American Power Conversion Back-UPS ES 750G FW:908.W3 .D USB FW:W3
    FiiO X3 7.62 GB
    Apple Inc. Display iSight
    Apple Inc. Apple LED Cinema Display
    Apple Inc. Display Audio
    VIA Labs, Inc. USB2.0 Hub

    Firewire Information: ℹ️
    G-TECH G-DRIVE 800mbit - 800mbit max
    EFI (disk2s1) <not mounted> : 210 MB
    iTunesHDMusic Library (G-Drive) (disk2s2) /Volumes/iTunesHDMusic Library (G-Drive) : 4.00 TB (482.61 GB free)

    Thunderbolt Information: ℹ️
    Apple Inc. thunderbolt_bus
    Apple Inc. Thunderbolt to FireWire Adapter

    Configuration files: ℹ️
    /etc/launchd.conf - Exists

    Gatekeeper: ℹ️
    Mac App Store and identified developers

    Kernel Extensions: ℹ️
    /Applications/Parallels Desktop.app
    [not loaded] com.parallels.kext.hypervisor (10.1.3 28868 - SDK 10.7) [Click for support]
    [not loaded] com.parallels.kext.netbridge (10.1.3 28868 - SDK 10.7) [Click for support]
    [not loaded] com.parallels.kext.usbconnect (10.1.3 28868 - SDK 10.7) [Click for support]
    [not loaded] com.parallels.kext.vnic (10.1.3 28868 - SDK 10.7) [Click for support]

    /Library/Extensions
    [loaded] at.obdev.nke.LittleSnitch (4240 - SDK 10.8) [Click for support]
    [loaded] com.squirrels.airparrot.framebuffer (5 - SDK 10.10) [Click for support]
    [loaded] com.squirrels.driver.AirParrotSpeakers (1.8 - SDK 10.8) [Click for support]
    [not loaded] foo.tap (1.0) [Click for support]
    [not loaded] foo.tun (1.0) [Click for support]

    /System/Library/Extensions
    [not loaded] com.Belcarra.iokit.USBLAN_netpart (2.0.2) [Click for support]
    [not loaded] com.Belcarra.iokit.USBLAN_usbpart (2.0.2) [Click for support]
    [loaded] com.Cycling74.driver.Soundflower (1.5.3 - SDK 10.6) [Click for support]
    [not loaded] com.RemoteControl.USBLAN.usbpart (2.0.6) [Click for support]
    [not loaded] com.dvdfab.kext.fabio (1) [Click for support]
    [not loaded] com.elgato.driver.DontMatchAfaTech (1.1) [Click for support]
    [not loaded] com.elgato.driver.DontMatchCinergy450 (1.1) [Click for support]
    [not loaded] com.elgato.driver.DontMatchCinergyXS (1.1) [Click for support]
    [not loaded] com.elgato.driver.DontMatchEmpia (1.1) [Click for support]
    [not loaded] com.elgato.driver.DontMatchVoyager (1.1) [Click for support]
    [loaded] com.globaldelight.driver.BoomDevice (1.1 - SDK 10.9) [Click for support]
    [not loaded] com.iospirit.driver.rbiokithelper (1.18.1 - SDK 10.6) [Click for support]
    [not loaded] com.makemkv.kext.daspi (1) [Click for support]
    [loaded] com.metakine.handsoff.driver (2.0.1 - SDK 10.6) [Click for support]
    [not loaded] com.nuforce.driver.nuforceUSBAudio (2.7.3f1) [Click for support]
    [not loaded] com.pctools.iantivirus.kfs (1.0.1) [Click for support]
    [not loaded] com.rogueamoeba.InstantOn (6.0.2 - SDK 10.6) [Click for support]

    /System/Library/Extensions/Belcarra.USBLAN_netpart.kext/Contents/PlugIns
    [not loaded] com.belcarra.iokit.netpart.panther (1.6.1) [Click for support]

    /System/Library/Extensions/Belcarra.USBLAN_usbpart.kext/Contents/PlugIns
    [not loaded] com.belcarra.iokit.usbpart.panther (1.6.1) [Click for support]

    /System/Library/Extensions/InstantOn.kext/Contents/PlugIns
    [not loaded] com.rogueamoeba.InstantOnCore (6.0.2 - SDK 10.6) [Click for support]

    /System/Library/Extensions/RBIOKitHelper.kext/Contents/PlugIns
    [not loaded] com.iospirit.driver.RBTSRPlugin (1.18 - SDK 10.6) [Click for support]

    /System/Library/Extensions/RemoteControl.USBLAN_usbpart.kext/Contents/PlugIns
    [not loaded] com.RemoteControl.USBLAN.panther (1.6.1) [Click for support]

    /Users/[redacted]/Library/Application Support/Boxcryptor/Boxcryptor 667/Boxcryptor.app
    [not loaded] com.boxcryptor.BCFS.filesystems.bcfs (3.0.2 - SDK 10.9) [Click for support]

    Startup Items: ℹ️
    tap: Path: /Library/StartupItems/tap
    tun: Path: /Library/StartupItems/tun
    Startup items are obsolete in OS X Yosemite

    Launch Agents: ℹ️
    [running] at.obdev.LittleSnitchUIAgent.plist [Click for support]
    [loaded] com.google.keystone.agent.plist [Click for support]
    [loaded] com.maintain.LogOut.plist [Click for support]
    [failed] com.maintain.PurgeInactiveMemory.plist [Click for support]
    [loaded] com.maintain.Restart.plist [Click for support]
    [loaded] com.maintain.ShutDown.plist [Click for support]
    [loaded] com.maintain.Sleep.plist [Click for support]
    [running] com.maintain.SystemEvents.plist [Click for support]
    [running] net.interacto.Flavours2AgentDaemon.plist [Click for support]
    [running] net.interacto.Flavours2AgentIgnitorDaemon.plist [Click for support]
    [running] org.chromium.chromoting.plist [Click for support]

    Launch Daemons: ℹ️
    [running] at.obdev.littlesnitchd.plist [Click for support]
    [loaded] com.adobe.fpsaud.plist [Click for support]
    [loaded] com.bombich.ccc.plist [Click for support]
    [running] com.bombich.ccchelper.plist [Click for support]
    [loaded] com.boxcryptor.BCFS.KextLoaderHelper.plist [Click for support]
    [running] com.cleverfiles.cfbackd.plist [Click for support]
    [loaded] com.google.keystone.daemon.plist [Click for support]
    [unknown] com.iOSinstaller.updd.plist [Click for support]
    [loaded] com.iospirit.candelair.daemon.plist [Click for support]
    [loaded] com.iospirit.candelair.sync.plist [Click for support]
    [loaded] com.klieme.TimeMachineScheduler.plist [Click for support]
    [loaded] com.macpaw.CleanMyMac2.Agent.plist [Click for support]
    [loaded] com.macpaw.CleanMyMac3.Agent.plist [Click for support]
    [not loaded] com.maintain.AutoLoginUserScreenLocked.plist [Click for support]
    [not loaded] com.maintain.CocktailScheduler.plist [Click for support]
    [not loaded] com.maintain.HideSpotlightMenuBarIcon.plist [Click for support]
    [failed] com.radiosilenceapp.nke.plist [Click for support]
    [failed] com.radiosilenceapp.nke.PrivateEye.plist [Click for support]
    [running] com.speedtools.scheduleagent.plist [Click for support]
    [loaded] com.subtlebllc.DiskWakeDaemon.plist [Click for support]
    [running] com.surteesstudios.hddfancontroldaemon.plist [Click for support]
    [running] com.trusteer.rooks.rooksd.plist [Click for support]
    [running] net.interacto.Flavours2Helper.plist [Click for support]
    [loaded] org.cindori.AuthHelper.plist [Click for support]
    [loaded] xxx.qnation.PeerGuardian.locum.plist [Click for support]

    User Launch Agents: ℹ️
    [loaded] com.adobe.ARM.[...].plist [Click for support]
    [loaded] com.macpaw.CleanMyMac3.Scheduler.plist [Click for support]
    [running] com.pia.pia_manager.plist [Click for support]
    [running] com.spotify.webhelper.plist [Click for support]
    [loaded] uk.co.markallan.clamxav.clamscan.plist [Click for support]
    [loaded] uk.co.markallan.clamxav.freshclam.plist [Click for support]

    User Login Items: ℹ️
    Macdrops v1.1 Application (/Applications/Macdrops v1.1.app)
    ClipBuddy Application (/Applications/ClipBuddy.app)
    Flux Application (/Applications/Flux.app)
    TabLauncher Application (/Applications/TabLauncher.app)
    PopClip Application (/Users/[redacted]/Applications/PopClip.app)
    Bartender Application (/Applications/Bartender.app)
    Calendar Application (/Applications/CalendarFree.app)
    CleanMyDrive Application (/Applications/CleanMyDrive.app)
    Growl Application (/Applications/Growl.app)
    HardwareGrowler Application (/Applications/HardwareGrowler.app)
    Wraparound Application (/Applications/Wraparound.app)
    Live Dock Weather Application (/Applications/Live Dock Weather.app)
    LoadInDock Application (/Applications/LoadInDock.app)
    ThermoInDock Application (/Applications/ThermoInDock.app)
    Dropbox Application (/Applications/Dropbox.app)
    EyeTV Helper Application (/Library/Application Support/EyeTV/EyeTV Helper.app)
    iBetterCharge Application (/Applications/iBetterCharge.app)
    MenuBarAudio Application (/Applications/MenuBarAudio.app)
    FoldersSynchronizer Application (/Applications/FoldersSynchronizer/FoldersSynchronizer.app)
    Boxcryptor Application (/Applications/Boxcryptor.app)
    AdobeResourceSynchronizer Application Hidden (/Applications/Adobe Reader.app/Contents/Support/AdobeResourceSynchronizer.app)
    TotalFinder Application (/Applications/TotalFinder.app)
    ClipMenu Application (/Applications/ClipMenu.app)
    Shazam Application (/Applications/Shazam.app)
    OneDrive Application (/Applications/OneDrive.app)
    StorageStatus Application (/Applications/StorageStatus.app)
    Memory Clean Application (/Applications/Memory Clean.app)
    SwitchResX Daemon Application Hidden (/Library/PreferencePanes/SwitchResX.prefPane/Contents/Resources/SwitchResX Daemon.app)
    Parcel Application (/Applications/Parcel.app)
    CrossOver CD Helper Application (/Users/[redacted]/Applications/CrossOver.app/Contents/Resources/CrossOver CD Helper.app)
    Stock + Pro Application (/Applications/Stock + Pro.app)
    System Monitor Application (/Applications/SystemMonitor.app)
    MacID Application (/Applications/MacID.app)
    CleanMyMac 3 Menu Application (/Applications/CleanMyMac 3.app/Contents/MacOS/CleanMyMac 3 Menu.app)
    CCC User Agent Application (/Applications/Carbon Copy Cloner.app/Contents/Library/LoginItems/CCC User Agent.app)
    MacID Application (/Applications/MacID.app)
    MacID Application (/Applications/MacID.app)

    Internet Plug-ins: ℹ️
    o1dbrowserplugin: Version: 5.41.0.0 - SDK 10.8 [Click for support]
    Default Browser: Version: 600 - SDK 10.10
    AdobePDFViewerNPAPI: Version: 10.1.14 [Click for support]
    FolxNetscapePlugIn: Version: Unknown
    FlashPlayer-10.6: Version: 17.0.0.169 - SDK 10.6 [Click for support]
    Silverlight: Version: 5.1.30514.0 - SDK 10.6 [Click for support]
    Flash Player: Version: 17.0.0.169 - SDK 10.6 Outdated! Update
    QuickTime Plugin: Version: 7.7.3
    googletalkbrowserplugin: Version: 5.41.0.0 - SDK 10.8 [Click for support]
    RogersOneNumber_67648: Version: 1.0.67648 - SDK 10.5 [Click for support]
    AdobePDFViewer: Version: 10.1.14 [Click for support]
    iPhotoPhotocast: Version: 7.0
    JavaAppletPlugin: Version: 15.0.0 - SDK 10.10 Check version

    User internet Plug-ins: ℹ️
    FolxNetscapePlugIn: Version: Unknown
    Picasa: Version: 1.0 - SDK 10.4 [Click for support]
    iGetterScriptablePlugin: Version: 2.9.3 [Click for support]
    Google Earth Web Plug-in: Version: 7.1 [Click for support]
    PSPlugin: Version: Unknown [Click for support]

    Safari Extensions: ℹ️
    LastPass
    Folx Safari Extension
    iGetter Extension
    Progressive Downloader Extension
    AutoPager
    Smart Scroll
    minimalGmail
    OmniBar Adware! [Click to remove]
    Turn Off the Lights
    Ebay Shopping Assistant Adware! [Click to remove]
    Amazon Shopping Assistant Adware! [Click to remove]
    Ultimate Status Bar
    Recent Tab List
    Searchme Adware! [Click to remove]
    Zoom
    GMail Counter
    Open in Internet Explorer
    Pushbullet
    SafariRestore
    Exposer
    Reload Button
    Widgets
    AdBlock

    Audio Plug-ins: ℹ️
    iWow: Version: Unknown [Click for support]
    Hear: Version: 1.1.0 - SDK 10.5 [Click for support]

    3rd Party Preference Panes: ℹ️
    Air Display Preferences [Click for support]
    Candelair [Click for support]
    remoting_host_prefpane [Click for support]
    Dashboard KickStart [Click for support]
    Flash Player [Click for support]
    FUSE for OS X (OSXFUSE) [Click for support]
    GeekTool [Click for support]
    HDD Fan Control [Click for support]
    Launchpad-Control [Click for support]
    Perian [Click for support]
    Rapport [Click for support]
    RedHand [Click for support]
    RestoreMeNot [Click for support]
    Smart Scroll [Click for support]
    SwitchResX [Click for support]
    TimeMachineScheduler [Click for support]

    Time Machine: ℹ️
    Skip System Files: NO
    Mobile backups: OFF
    Auto backup: YES
    Volumes being backed up:
    Macintosh HD: Disk size: 499.10 GB Disk used: 345.98 GB
    Destinations:
    Data [Network]
    Total size: 2.00 TB
    Total number of backups: 50
    Oldest backup: 2015-04-21 04:58:16 +0000
    Last backup: 2015-06-02 14:59:54 +0000
    Size of backup disk: Excellent
    Backup size 2.00 TB > (Disk size 499.10 GB X 3)

    Top Processes by CPU: ℹ️
    14% WindowServer
    9% firefox
    5% Little Snitch Agent
    4% BitTorrent
    4% fontd

    Top Processes by Memory: ℹ️
    1.76 GB firefox
    1.50 GB kernel_task
    946 MB Twitter
    745 MB WindowServer
    545 MB Finder

    Virtual Memory Information: ℹ️
    6.16 GB Free RAM
    22.00 GB Used RAM
    0 B Swap Used

    Diagnostics Information: ℹ️
    Jun 2, 2015, 08:30:14 AM Self test - passed
    Jun 1, 2015, 11:30:03 PM /Users/[redacted]/Library/Logs/DiagnosticReports/plugin-container_2015-06-01-233003_[redacted].crash
    Jun 1, 2015, 12:16:25 PM /Users/[redacted]/Library/Logs/DiagnosticReports/iTunes_2015-06-01-121625_[redacted].crash
    May 31, 2015, 08:03:40 AM /Users/[redacted]/Library/Logs/DiagnosticReports/callservicesd_2015-05-31-080340_[redacted].crash
    May 31, 2015, 03:32:05 AM /Users/[redacted]/Library/Logs/DiagnosticReports/plugin-container_2015-05-31-033205_[redacted].crash
    May 30, 2015, 11:52:28 AM /Users/[redacted]/Library/Logs/DiagnosticReports/plugin-container_2015-05-30-115228_[redacted].crash
     
  2. rkaufmann87 macrumors 68000

    rkaufmann87

    Joined:
    Dec 17, 2009
    Location:
    Folsom, CA
    #2
    You also may want to post an EtreCheck report of your system, at least we can then get a more detailed picture of how your system is configured.
     
  3. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #3
    This is a common issue seen on the apple message boards, it seems that any Hardware kexts. added before the release of mavericks can cause some serious issues, deleting them can sort it out.

    things like old printer drivers and kexts for blackberry mobiles etc

    see here for details

    https://discussions.apple.com/thread/5489041?start=30&tstart=0
     
  4. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #4
    Thank you. I deleted the kexts for a HP printer (from 2009 !!) and now all is well.
     
  5. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #5
    The kext for the HP printer has reappeared !! I deleted it. Emptied the trash and restarted. It seemed to be gone. Today I looked in the Extension folder and it had reinstalled itself. It is identified as hp_io_enabler_compound. text How do I get rid of this item ?
     
  6. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #6
    I may be mistaken here, but don't you need to remove the kext cache after you have deleted a kext?

    Others in the know, please jump in with the answer...
     
  7. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #7

    Where do I find the Kext cache ??
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    That Etrecheck report lists four, separate adware extensions you have running. You should download and run AdwareMedic to get rid of them.

    http://www.adwaremedic.com/index.php
     
  9. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #9
    Thanks you for this - this was incredibly useful, had been doing this manually for yonks.
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    Does everything seem to be fixed up now? I notice you have a TON of startup and login items, and often those can cause problems.

    If you are still having trouble, try a boot to safe mode by holding the shift key as you boot. That will bypass all startup and login items. If the trouble goes away in safe mode, that tells you one of your startup or login items is the problem.

    https://support.apple.com/en-us/HT201262
     
  11. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #11
    Thanks again,
    You really are an incredible source of knowledge, and very patient with us ludlites :p

    If my memory serves me correctly, you were very helpful during the dark days of the early ssds, pre trim-enabler, when every other ssd from ocz would fail, don't think i ever thanked you properly matey.
     
  12. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #12
    The problem is still there. Still can't seem to get rid of, hp_io_enabler_compound.kext. I delete it. Then a day later it is back again.
     
  13. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #13
    Try the safe mode boot I mentioned then delete it and restart and see if that kills it.
     
  14. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #14
    OK, I tried booting into safe mode. I get to the log in screen but I can't log in. My best guess is that my apple wireless keyboard is not working in safe mode. Now what ?? :(
     
  15. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #15
    Hmm... my wireless KB works from safe mode. What happens when you do an up or down arrow? Does that select the login box?

    Do you have an old USB KB you can try?
     
  16. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #16
    I didn't try the up and down arrows because the cursor was already within the login window. But the cursor was not blinking. I don't have a USB keyboard
     
  17. nutcaseguy thread starter macrumors newbie

    Joined:
    Oct 17, 2011
    #17
    I tried again to boot into safe mode. It takes a good 5-10 minutes before the login in window appears. I still cannot type to login with the wireless keyboard, although occasionally I can get a letter or two to appear.
     

Share This Page