Out of control fans

Discussion in 'MacBook Air' started by mo-at-mr, Aug 27, 2013.

  1. mo-at-mr macrumors newbie

    Joined:
    Aug 27, 2013
    #1
    Lately the fans on my mid 2011 MBA switch on with minimal use and run at high speeds. I have noticed that this started happening more frequently once I started using Firefox instead of Chrome, but it was happening even before.

    Screen shots of activity monitor and Istat included. As you can see fans are running at > 6000 RPM and the cpu is 91% idle...
     

    Attached Files:

  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    Simple solution is stop using Firefox. I'd say that app is not too friendly to Macs, i've read a number of problems with it. Perhaps its ramping up the cpu cycles to a point where the system thinks it needs increased cooling.
     
  3. mo-at-mr thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #4
    I've done an SMC reset and didn't seem to help things.

    Is there any other possible explanation for this situation? Like I said, CPU usage is really low and the thing sounds like a 747....

    I'd like to keep using FF is possible as I'm concerned about privacy and Mozilla is about the only organization I trust that will respect my rights, but if it really is FF that's causing this then I'll just go back to Conkeror.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #5
    If its only happening with firefox, then its not hardware related but due to the software. I don't use firefox, so I can't say for sure.

    Is it in general use, or going to specific sites? Also do you have any plugins installed?
     
  5. mo-at-mr thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #6
    General use, doesn't really matter which site I'm on.

    Minimal plugins like HTTPSeverywhere, FlashBlocker, and NoScript.
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    Remove the plugins, and see if the issue continues.
     
  7. mo-at-mr thread starter macrumors newbie

    Joined:
    Aug 27, 2013
    #8
    I disactivated them before and that didn't help either.

    And lo and behold, out of the blue the fans just dropped to ~4000 RPM without any change in programs open and CPU usage.

    I'm starting to think that there might be some sort of malware running? Does this happen often on Macs?

    Or could it be the surface it's being used on?
     
  8. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #9
    what kind of surface ARE you using it on?
    I stopped using firefox a few years ago for pretty much this exact reason.
    i am sure it was some plugin, but i never figured out which one and chrome is just as good in my opinion so i'm 100% chrome now. well, 90% chrome and 10% safari (i have two google accounts, 1 for work, so i like to use one in each browser)

    if you are set on staying w/ ff, at the very least i would uninstall it completely and start over.
     

Share This Page