Outlook for Mac in Yosemite

Discussion in 'OS X Yosemite (10.10)' started by lulla01, Oct 16, 2014.

  1. lulla01 macrumors 68020

    lulla01

    Joined:
    Jul 13, 2007
    Location:
    U.S
    #1
    Can anyone confirm Outlook's issues have been fixed in 10.10?

    I don't want to upgrade and be SOL.
     
  2. flipshot macrumors 6502a

    Joined:
    Jul 30, 2007
    Location:
    Hertfordshire, UK
    #2
    What are the specific issues in 10.10, I have been using it on 10.10 but it seems just as buggy as it has been on Mavericks (constant Beachballing despite numerous reinstalls).
     
  3. irnchriz macrumors 65816

    irnchriz

    Joined:
    May 2, 2005
    Location:
    Scotland
    #3
    Outlook was always a bit want till I put an SSD in my Macbook. Now its fine. Runs ok in Yosemite too. Only setup with 1 Exchange account, the other accounts are all in Mail.
     
  4. lulla01 thread starter macrumors 68020

    lulla01

    Joined:
    Jul 13, 2007
    Location:
    U.S
    #4
    I am worried about shared calendars specifically.
    Microsoft is really dropping the ball with this.
     
  5. flipshot macrumors 6502a

    Joined:
    Jul 30, 2007
    Location:
    Hertfordshire, UK
    #5
    They have been working ok for me, well as OK as in Mavericks.

    We still have Exchange 2007 at work which I think might be the cause of some of my Outlook issues. Should hopefully be going up to 2013/Office 365 later this year.
     
  6. Zulu33301 macrumors newbie

    Joined:
    May 4, 2009
    #6
    os x yosemite / microsoft exchange 2007

    Hi All,

    Anyone having any issues with sending emails with microsoft exchange 2007 on os x yosemite? It was working fine after the upgrade and then today, can't send or receive? My iPhone and iPad work fine, no issues.

    Any help would be greatly appreciated.
     
  7. danish. macrumors newbie

    danish.

    Joined:
    Oct 25, 2012
    Location:
    Copenhagen, Denmark
    #7
    I installed the new Outlook last night, so far I'm happy with it - except for the power consumption! Temperature rises and fans run around 5000 RPM as long as Outlook is open. Battery life on my 2013 MBA is down to about 2 hrs! :mad:

    Anyone else have this problem? Running Yosemite, btw.
     

Share This Page