Over 2 Terabytes missing?!?

Discussion in 'Mac Basics and Help' started by rlolson2, Nov 29, 2011.

  1. rlolson2 macrumors newbie

    Joined:
    Nov 25, 2011
    #1
    I had a 3 TB HD which was mistakenly plugged into a Windows 7 laptop losing everything on the drive and corrupting it. The good news was that I was able recover all my media off the drive with software, the bad news is that my MBP thinks that the drive is only 800 gigs large now? I was able to create a new partition but my computer says it is only 800 gigs. Is there any way I can recover all the missing space and clean out the drive from scratch?
     
  2. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #2
    Just use Disk Utility to reformat the drive as an HFS+ disk.
     
  3. rlolson2 thread starter macrumors newbie

    Joined:
    Nov 25, 2011
    #3
    I've tried that and it still says the disk is only 810 gig big.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    To reclaim the space from all partitions, use Disk Utility and repartition it to 1 partition.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    If you can't figure it out then type "diskutil list" in Terminal and post the output here.
     
  6. rlolson2 thread starter macrumors newbie

    Joined:
    Nov 25, 2011
    #6
    /dev/disk1
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *801.6 GB disk1
    1: EFI 209.7 MB disk1s1
    2: Apple_HFS Media 2 801.2 GB disk1s2


    I only have one partition. The space is just totally missing.
     
  7. eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #7
    Use Disk Utility and erase the entire drive then re partition it as 1 partition. The other partition is damaged and cannot be seen. Once you erase the entire disk and re partition it that's how it will look to your Mac.
     
  8. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #8
    What GGJstudios said is the answer, but in case it wasn't clear enough:

    Open Disk Utility. Select the drive itself in the list at left (that is, the least-indented item that has some kind of hardware name followed by "Media", rather than the indented partition beneath it).

    Select the "Partition" tab, and under "Partition Layout", select "1 Partition" (do this even if there is only one partition showing currently--it's the key point). Just to be sure, also click "Options" and make sure GUID is selected.

    Finally, click "Apply" at lower right, confirm when it tells you it's going to erase everything on the disk, and you should be good.

    If that doesn't work, post back.
     
  9. rlolson2 thread starter macrumors newbie

    Joined:
    Nov 25, 2011
    #9
    [​IMG]

    Tried that and it still thinks the drive is only 800 gig large.
     
  10. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #10
    Hmm... I have vague memories of a drive that got something hosed in the partition map such that even what I suggested wasn't sufficient to restore it to a clean state, but I haven't seen a case like that in years. Usually, though, the hardware item (the least indented one in Disk Utility) shows the hardware capacity regardless of what has happened to the partition map.

    Assuming it's not a hardware problem (which it probably isn't), you could try what eljanitor suggests and select the drive in the list and instead of using the Partition tab go to Erase and use that. Go ahead and let it erase even if it looks like it will only be 800GB, and it's possible after the erase (when it has finished wiping it) you'll be able to repartition to the full size.

    It's also possible that the case is doing something odd based on WD-specific commands it got from Windows (maybe WD's software was installed?). In which case the solution might actually be to download whatever Windows software WD gives out with the drive, hook it to a Windows box, and try to completely wipe it there (and/or reformat using GPT to whatever--you can always repartition later on the Mac). A quick search does come up with a few similar-sounding cases to yours, the generally suggested solution for which (apart form using GPT, which is a given on a Mac now) is using WD's tools to wipe the drive.

    Even if my suggestions turn out to be useless, please do tell us when you eventually figure it out--it'll be useful for future reference.
     

Share This Page