Over 25gb of space disappeared!

Discussion in 'OS X Mountain Lion (10.8)' started by ehmjay, Jul 20, 2013.

  1. ehmjay macrumors member

    Apr 26, 2006
    Here's my problem: over the past couple days I did a really good clean out of my computer and managed to free up several gigabytes of data and was hovering around 233+ gb of free space.

    Then in the last couple of days I noticed my trash file was taking a really long time to empty (I don't know if this is part of the problem but wanted to mention it just in case).

    Last night I noticed I was missing quite a lot of space on my drive, it was around 205 gigs now. I discovered I had accidentally set some large torrent files to be on my main drive instead of an external. No matter, I figured! I would just delete them and start them over on the external. But my disk space didn't seem to change. So I rebooted - after all I had recently used Photoshop and that tends to hog a bunch of space and I don't get it back until I reboot.

    I rebooted and there was still the same ~205 gb of free space. I was very confused. I was even more confused when I checked "About My Mac" and saw that it was telling me that in actual fact I only had around 90gbs of free space. THE HECK!?

    I did notice that my "backups" were surprisingly high - 119gb in fact. This was especially curious since I have a time machine drive (time capsule) thats supposed to be backing up hourly. I did get a message this morning telling me it was full, but isn't it supposed to clear itself out?

    Running WhatSize (it's still running by the way) I see that my .MobileBackups folder is a gargantuan 134gb! I thought these were temporary! For when I'm not connected to Time Machine (WHICH I AM!)

    What in the hell is going on? How did I magically lose close to 25 gigs? And how the hell do I get it back?
  2. ehmjay, Jul 20, 2013
    Last edited: Jul 20, 2013

    ehmjay thread starter macrumors member

    Apr 26, 2006
    So a little more digging lead me to think it was the local backups so I ran
    sudo tmutil disablelocal
    which removed the MobileBackups folder. Popped open "About this mac" to look at the storage section" and...

    It's still showing only 90 gbs free (with my Finder window showing 209).

    And here's the REALLY crazy part, the portion that used to be taken up by "mobile backups" is now filled be the "other" block.

    Now I'm completely confused.

    UPDATE: Rebooted and things were fine. So clearly it was related to the time machine snapshots.

Share This Page