Overriding Mac file permissions in Linux

Discussion in 'macOS' started by luminol74, Dec 4, 2008.

  1. luminol74 macrumors member

    Apr 17, 2008
    Hello all,

    I'm trying to recover a some data from a LaCie EDMini drive because the caddie went down. There are application solutions out there including R-Studio and Data Recovery II but they are both ~$80 solutions and don't always recover the metadata meaning I'd be renaming hundreds and hundreds of files which isn't going to happen!

    Anyway, I'm using a SATA to USB adapter and I loaded up an Ubuntu Live CD to look at the file system and presto it mounted all my files. Brilliant. Only problem is that I had this EDMini in a network with Windows and Mac machines and I've been able to recover all files that were created on Windows but the files that were created on OS X (all my files...) are locked. It tells me I don't have permission to access the files.

    Whilst that boosts my confidence in OS X security I do need to bypass those permissions somehow and my knowledge of Linux is poor. I tried sudo cp commands but was getting nowhere. Then decided to create a username and password that was identical to my OS X username and password to see if that worked and it doesn't. :(

    Is anyone familar with this situation or knows how to override OS X file permissions so I can copy the files onto another drive?

    Help appreciated, thanks.

  2. detz macrumors 65816

    Jun 29, 2007
    You might not be able to change them on the drive you might have to move them off first. Then you can use either...


    which will give your linux user(YOURNAME) ownership of all of the files in FOLDERNAME

    Or you can change the permissions on all the files
    chmod -R 777 FOLDERNAME

    You will have to be sudo for these to work correctly
  3. luminol74 thread starter macrumors member

    Apr 17, 2008
    detz I could kiss you! chmod -R 777 has worked an absolute treat. No idea what the command actually means but it's just saved me a thousand files or more. Thanks for the tip!

  4. brand macrumors 601


    Oct 3, 2006
    Wikipedia's take on CHMOD
  5. macrem macrumors 65816


    Mar 11, 2008
    edit: doe anyone know why the sudo command from Ubuntu didn't work for the OP? I would have guessed it would, especially since chmod worked.

Share This Page