OWC dock restarting MB - Problem

Discussion in 'MacBook' started by saback, Nov 7, 2016.

  1. saback macrumors member

    Joined:
    Mar 22, 2011
    #1
    Hi Everyone,

    I purchased a OWC do few weeks ago to allow me to use the Ethernet and HDMI ports at the same time at my MB. It worked well for few weeks but after few weeks it started to reboot my computer when the HDMI monitor was connected. I open a ticket with them and it was recommended to reset SMC and PRAM to solve the problem.

    The problem started to happen twice a week by I could fix reseting the SMC and PRAM. It was annoying but at least I could use it. Few days ago a applied the latest patch to my MB (macOS Sierra 10.12.1) and since than if I connect the dock without any other port connected (just the power) it restart my MB and I already tried the SMC and PRAM reset with no success.

    They offered a RMA but it will cost me $70 to send it from Australia to US and I really don't want to spend almost half of the cost of the device to RMA it and OWC refused to reimburse the shipping cost (what remindes me never buy from them again). I'm not an expert but sounds like a driver problem or something related to that. Does anyone here experience the same issue? Any clue on how to fix it? Any way of reinstalling the drivers?

    Thanks

    Below the crash report

    Log:

    Anonymous UUID: F058C9DE-FAE8-3455-6696-792772690F90

    Wed Oct 26 08:52:08 2016

    *** Panic Report ***

    panic(cpu 1 caller 0xffffff80136065ea): Kernel trap at 0xffffff8013a92b86, type 13=general protection, registers:

    CR0: 0x000000008001003b, CR2: 0x000000010fede000, CR3: 0x0000000240a4b061, CR4: 0x00000000003627e0

    RAX: 0x3f00110982efc41c, RBX: 0xffffff803430bc80, RCX: 0x0000000000020001, RDX: 0xffffff803430bc80

    RSP: 0xffffff911fdf37e0, RBP: 0xffffff911fdf3830, RSI: 0x00000000e0000100, RDI: 0xffffff803430bc80

    R8: 0x0000000000000000, R9: 0xffffff7f94103240, R10: 0x0000000000000000, R11: 0x0000000000000003

    R12: 0x00000000e0000100, R13: 0xffffff8034ab5000, R14: 0x00000000e00002c2, R15: 0x0000000000020001

    RFL: 0x0000000000010282, RIP: 0xffffff8013a92b86, CS: 0x0000000000000008, SS: 0x0000000000000000

    Fault CR2: 0x000000010fede000, Error code: 0x0000000000000000, Fault CPU: 0x1, PL: 0

    Backtrace (CPU 1), Frame : Return Address

    0xffffff8114eb5df0 : 0xffffff80134f368c

    0xffffff8114eb5e70 : 0xffffff80136065ea

    0xffffff8114eb6050 : 0xffffff80134a5743

    0xffffff8114eb6070 : 0xffffff8013a92b86

    0xffffff911fdf3830 : 0xffffff8013a913cd

    0xffffff911fdf3860 : 0xffffff7f940c745d

    0xffffff911fdf38e0 : 0xffffff8013a91234

    0xffffff911fdf3940 : 0xffffff7f940c7214

    0xffffff911fdf3990 : 0xffffff7f940b857f

    0xffffff911fdf39f0 : 0xffffff8013abf4fa

    0xffffff911fdf3a60 : 0xffffff7f940b8453

    0xffffff911fdf3ac0 : 0xffffff7f940b8240

    0xffffff911fdf3b20 : 0xffffff8013ae5041

    0xffffff911fdf3b80 : 0xffffff8013aee181

    0xffffff911fdf3cc0 : 0xffffff80135c5f28

    0xffffff911fdf3dd0 : 0xffffff80134f843c

    0xffffff911fdf3e30 : 0xffffff80134d5f61

    0xffffff911fdf3e80 : 0xffffff80134e9957

    0xffffff911fdf3f10 : 0xffffff80135f26ae

    0xffffff911fdf3fb0 : 0xffffff80134a5f66

    Kernel Extensions in backtrace:

    com.apple.iokit.IOUSBFamily(900.4.1)[365596E4-A771-3427-B576-DB02D03FAEFE]@0xffffff7f94097000->0xffffff7f94130fff

    dependency: com.apple.iokit.IOPCIFamily(2.9)[C29002A1-DF76-3A8E-8D67-D70922DF86AE]@0xffffff7f93d32000

    dependency: com.apple.iokit.IOUSBHostFamily(1.1)[39E90AC4-0FCA-3CBD-80B2-3CBCD82940DC]@0xffffff7f94026000

    BSD process name corresponding to current thread: Google Chrome

    Mac OS version:

    16B2555

    Kernel version:

    Darwin Kernel Version 16.1.0: Thu Oct 13 21:26:57 PDT 2016; root:xnu-3789.21.3~60/RELEASE_X86_64

    Kernel UUID: 8941AC1C-B084-37DE-8A34-4CE638C5CFC9

    Kernel slide: 0x0000000013200000

    Kernel text base: 0xffffff8013400000

    __HIB text base: 0xffffff8013300000

    System model name: MacBook8,1 (Mac-BE0E8AC46FE800CC)

    System uptime in nanoseconds: 22501438568579

    last loaded kext at 22501425885849: com.realtek.driver.AppleRTL815XEthernet 1.0.15 (addr 0xffffff7f965f5000, size 233472)

    last unloaded kext at 13820727395794: com.apple.driver.IOBluetoothHIDDriver 5.0.1f7 (addr 0xffffff7f94a9c000, size 106496)

    loaded kexts:

    com.realtek.driver.AppleRTL815XEthernet 1.0.15

    com.realtek.driver.AppleRTL815XComposite 1.0.15

    com.parallels.kext.vnic 11.2.2 32651

    com.parallels.kext.netbridge 11.2.2 32651

    com.parallels.kext.hypervisor 11.2.2 32651

    com.parallels.kext.usbconnect 11.2.2 32651

    com.avg.Antivirus.OnAccess.kext 2016.0

    com.apple.driver.usb.AppleUSBHostBillboardDevice 1.0

    com.apple.driver.AppleHSBluetoothDriver 103

    com.apple.filesystems.afpfs 11.0.1

    com.apple.nke.asp-tcp 8.0.1

    com.apple.filesystems.smbfs 3.1

    com.apple.driver.AudioAUUC 1.70

    com.apple.driver.AGPM 110.23.11

    com.apple.driver.X86PlatformShim 1.0.0

    com.apple.driver.ApplePlatformEnabler 2.7.0d0

    com.apple.filesystems.autofs 3.0

    com.apple.driver.AppleGraphicsDevicePolicy 3.13.74

    com.apple.driver.AppleUpstreamUserClient 3.6.4

    com.apple.driver.AppleOSXWatchdog 1

    com.apple.driver.AppleHDA 278.23

    com.apple.driver.pmtelemetry 1

    com.apple.driver.AppleIntelBDWGraphics 10.2.0

    com.apple.iokit.IOUserEthernet 1.0.1

    com.apple.iokit.IOBluetoothSerialManager 5.0.1f7

    com.apple.Dont_Steal_Mac_OS_X 7.0.0

    com.apple.driver.AppleHV 1

    com.apple.driver.AppleLPC 3.1

    com.apple.driver.AppleIntelBDWGraphicsFramebuffer 10.2.0

    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

    com.apple.driver.AppleSMCLMU 208

    com.apple.driver.AppleCameraInterface 5.57.0

    com.apple.driver.AppleBacklight 170.9.10

    com.apple.driver.AppleMCCSControl 1.2.13

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

    com.apple.BootCache 40

    com.apple.filesystems.hfs.kext 366.1.1

    com.apple.driver.AppleTopCaseHIDEventDriver 103

    com.apple.driver.AirPort.Brcm4360 1110.4.1a8

    com.apple.driver.AppleRTC 2.0

    com.apple.driver.AppleSmartBatteryManager 161.0.0

    com.apple.driver.AppleACPIButtons 5.0

    com.apple.driver.AppleHPET 1.8

    com.apple.driver.AppleSMBIOS 2.1

    com.apple.driver.AppleACPIEC 5.0

    com.apple.driver.AppleAPIC 1.7

    com.apple.nke.applicationfirewall 172

    com.apple.security.quarantine 3

    com.apple.security.TMSafetyNet 8

    com.apple.driver.AppleUSBAudio 305.62

    com.apple.driver.usb.IOUSBHostHIDDevice 1.1

    com.apple.driver.usb.cdc 5.0.0

    com.apple.driver.usb.networking 5.0.0

    com.apple.driver.usb.AppleUSBHostCompositeDevice 1.1

    com.apple.driver.usb.AppleUSBHub 1.1

    com.apple.driver.IOBluetoothHIDDriver 5.0.1f7

    com.apple.security.SecureRemotePassword 1.0

    com.apple.kext.triggers 1.0

    com.apple.driver.DspFuncLib 278.23

    com.apple.kext.OSvKernDSPLib 525

    com.apple.iokit.IOBluetoothHostControllerUARTTransport 5.0.1f7

    com.apple.iokit.IOBluetoothHostControllerTransport 5.0.1f7

    com.apple.iokit.IOSurface 153.1

    com.apple.iokit.IOBluetoothFamily 5.0.1f7

    com.apple.driver.AppleHDAController 278.23

    com.apple.iokit.IOHDAFamily 278.23

    com.apple.iokit.IOAudioFamily 205.11

    com.apple.vecLib.kext 1.2.0

    com.apple.driver.AppleGraphicsControl 3.13.74

    com.apple.AppleGraphicsDeviceControl 3.13.74

    com.apple.iokit.IOAcceleratorFamily2 288.15

    com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0

    com.apple.driver.X86PlatformPlugin 1.0.0

    com.apple.driver.IOPlatformPluginFamily 6.0.0d8

    com.apple.driver.AppleIntelLpssUARTv0 3.0.60

    com.apple.driver.AppleIntelLpssUARTCommon 3.0.60

    com.apple.iokit.IOSerialFamily 11

    com.apple.driver.AppleBacklightExpert 1.1.0

    com.apple.iokit.IONDRVSupport 2.4.1

    com.apple.driver.AppleSMC 3.1.9

    com.apple.driver.AppleSMBusController 1.0.14d1

    com.apple.iokit.IOGraphicsFamily 2.4.1

    com.apple.iokit.IOSCSIArchitectureModelFamily 394

    com.apple.driver.CoreStorage 540

    com.apple.filesystems.hfs.encodings.kext 1

    com.apple.driver.AppleHIDKeyboard 197

    com.apple.driver.AppleMultitouchDriver 368.4

    com.apple.driver.AppleInputDeviceSupport 76.4

    com.apple.driver.AppleHSSPIHIDDriver 49

    com.apple.iokit.IONVMeFamily 2.1.0

    com.apple.iokit.IO80211Family 1200.12.2

    com.apple.driver.mDNSOffloadUserClient 1.0.1b8

    com.apple.iokit.IONetworkingFamily 3.2

    com.apple.driver.corecapture 1.0.4

    com.apple.driver.AppleHSSPISupport 49

    com.apple.driver.AppleHPM 3.0.9

    com.apple.iokit.IOThunderboltFamily 6.2.3

    com.apple.driver.usb.AppleUSBHostPacketFilter 1.0

    com.apple.iokit.IOUSBFamily 900.4.1

    com.apple.driver.AppleIntelLpssSpiController 3.0.60

    com.apple.driver.AppleIntelLpssI2CController 3.0.60

    com.apple.driver.AppleIntelLpssDmac 3.0.60

    com.apple.driver.AppleIntelLpssI2C 3.0.60

    com.apple.driver.AppleIntelLpssGspi 3.0.60

    com.apple.driver.usb.AppleUSBXHCIPCI 1.1

    com.apple.driver.usb.AppleUSBXHCI 1.1

    com.apple.iokit.IOUSBHostFamily 1.1

    com.apple.driver.AppleUSBHostMergeProperties 1.1

    com.apple.driver.AppleEFINVRAM 2.1

    com.apple.driver.AppleEFIRuntime 2.0

    com.apple.driver.AppleBusPowerController 1.0

    com.apple.iokit.IOHIDFamily 2.0.0

    com.apple.iokit.IOSMBusFamily 1.1

    com.apple.security.sandbox 300.0

    com.apple.kext.AppleMatch 1.0.0d1

    com.apple.driver.AppleKeyStore 2

    com.apple.driver.AppleMobileFileIntegrity 1.0.5

    com.apple.driver.AppleCredentialManager 1.0

    com.apple.driver.DiskImages 444.20.3

    com.apple.iokit.IOStorageFamily 2.1

    com.apple.iokit.IOReportFamily 31

    com.apple.driver.AppleFDEKeyStore 28.30

    com.apple.driver.AppleACPIPlatform 5.0

    com.apple.iokit.IOPCIFamily 2.9

    com.apple.iokit.IOACPIFamily 1.4

    com.apple.kec.Libm 1

    com.apple.kec.pthread 1

    com.apple.kec.corecrypto 1.0

    Model: MacBook8,1, BootROM MB81.0164.B18, 2 processors, Intel Core M, 1.3 GHz, 8 GB, SMC 2.25f87

    Graphics: Intel HD Graphics 5300, Intel HD Graphics 5300, Built-In

    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x4544464231363441314D412D47442D462020

    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x4544464231363441314D412D47442D462020

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x131), Broadcom BCM43xx 1.0 (7.21.171.47.1a8)

    Bluetooth: Version 5.0.1f7, 3 services, 27 devices, 0 incoming serial ports

    USB Device: USB 3.0 Bus

    Thunderbolt Bus:
     

    Attached Files:

  2. Armski macrumors regular

    Joined:
    May 28, 2015
    Location:
    Englishman in NY
    #2
    Looking at your picture i see you are using the Apple USB-C cable. The dock should have come with a black thicker USB-C cable which is 5gb/sec USB3.1 i think. The apple one is only 480mb USB2.

    I owned the dock but returned it as it did not like my Dell 19inch LCD using a DVI to HDMI connection.

    I would suggest trying a different uplink cable to your macbook. Try the one supplied with the dock or buy a good 5gb or 10gb/sec USB-C cable. Hopefully then the mac will not crash. Probably lack of bandwidth with the apple cable. Cheaper than sending the Dock back.

    Good luck!
     
  3. saback thread starter macrumors member

    Joined:
    Mar 22, 2011
    #3
    Hi Armski,

    Thanks for the reply. I was using the Apple cable just for testing but the problem started using the provided cable.
    After a number of tests and emails with their support seems that the problem is with their Ethernet driver. I removed the driver today and so far the dock is working. Let's see if it will fix the problem.

    Thanks,
    Saback
     

Share This Page