OWC Guardian Maximus USB 3 issues

Discussion in 'Mac Accessories' started by itsamacthing, Feb 1, 2013.

  1. itsamacthing macrumors 6502a

    Sep 26, 2011
    Just a heads up: bought one 6 months ago with the plan to use it on USB 3 with my new imac. Plugged it into my USB 3 port today and it crashed my MBAir. After many frustrating hours, OWC blamed it on Apple..and the tech was rude and aggressive with me. Like its my fault! I've dealt with tech support from many companies, but this is the second time an OWC tech support person has gotten aggressive and rude. The last time was when my OWC 6G SSD was bad...again, this is my fault and I should be yelled at.

    Well, the good news is that the Guardian Maximus is fixable via a firmware update... Bad news is that the tech from OWC with a bad attitude can not be fixed. I'm done doing business with them and don't know why they get so many awards. I have had nothing but problems.
  2. g4cube macrumors 6502a

    Apr 22, 2003
    How could it be Apple's fault when there are so many USB 3.0 products that seem to work quite well with the new Macs with USB 3.0?

    You are correct, there is no excuse for the support rep to say this, and to be so unhelpful. Especially when there actually is a solution!
  3. cosmicjoke macrumors 6502

    Oct 3, 2011
    Portland, OR
    The MBA kernel panicked? Did it do it instantly when plugging it in or during a file transfer or while idling? Whose firmware update? Apple needs to release one? Just curious.
  4. jterp7 macrumors 6502a

    Oct 26, 2011
    heh nothing like bad publicity, i'll keep your story in mind next time i consider making a purchase from them. Almost did a few months ago.
  5. itsamacthing thread starter macrumors 6502a

    Sep 26, 2011
    That's just it, I have older USB 3 devices that work just fine with my MBA ... He had nothing but excuses. "Apple is using a unique USB 3 driver" "Apple just released their first USB 3 device in June".

    What a load, they had the same Apple excuses when my over priced 6G OWC SSD failed to perform as advertised. Must be apple's fault, and the Blackmagic speed test is not accurate!


    My imac is still shipping, but when I plugged it into the USB2 on my mini, no issues. But plug it into USB3, and it will kernel panic your machine to death. It's OWC firmware...will update today and then update you all
  6. itsamacthing thread starter macrumors 6502a

    Sep 26, 2011
    Another thing, the device has a toggle inside to set RAID level. It support 0,1,JBOD, and Independent. Yet, the support rep says he can only talk to me about 1, the chip supports the rest ... But "OWC" did not design the rest of the device to support 0,JBOD, or independent. What a load!

    My experience with OWC is that they have a big attitude about their products, and that nothing could ever go or be wrong with them. It's always someone else's fault. It would be nice if they just take responsibility and provided attitude free support.

    No doubt, I'll be avoiding them in the future. I'll never use their SSDs again. It took them a year, replacement, and 3 firmware updates before their 6G SSD was stable in my 2011 Mini. It was my work computer ... The coming back to my desk to find a frozen or crashed system was costly.
  7. itsamacthing thread starter macrumors 6502a

    Sep 26, 2011

    Finally got my Guardian Maximus updated to the correct firmware and it's performing nicely over USB3. r/w 140 in Raid 1, and r/w 180 in Raid 0. Using WD Red drives.
  8. Skeli macrumors newbie


    May 23, 2009
    Any chance you can post a link to the firmware update? I've been looking and can't find it anywhere..
  9. a.m.c. macrumors newbie

    Feb 9, 2013
    Thanks for the helpful information.

    I'm considering purchasing this enclosure, but was hesitant about the ability to change RAID modes. I've read enough forum posts and reviews stating the hardware RAID-1 is unstable and fails fairly consistently, which makes me want to have the option of creating a software RAID-1 or use the enclosure as a RAID-0.

    My machine doesn't have USB 3.0 yet, but I'm looking forward to using it when I upgrade.

    Where did you obtain the Firmware Updates?

  10. nuno1959 macrumors member

    Oct 19, 2009
    installing Guardian Maximus USB 3.0 firmware….

    hi guys

    talk about reviving an old thread ! :-b but fact is i'm having the exact same USB 3 troubles w/ my G-Max & i have never installed a firmware before - at least using Crossover

    can anyone here explain to me how to go about it ? i would hate to do something g wrong & funk up my enclosures or worse, my data !!

    many thanks

    oh by the way, someone asked for a link to the firmware, here it is :

    http://home2.owc.net/~tech/OWC/Firmware/USB 3/USB 3 GMAX FirmwareUpdater (xp and 7 32-bit only).zip

    got it just now from OWC, hope that helps

    cheers guys
  11. pjny macrumors 6502a

    Feb 18, 2010
    I had the same issue with a 2012-13 version of the GM: firewire 800 worked but connecting via USB 3 would just hang my computer. OWC was no help and said I had to buy the new version of the GM due to USB 3 issues on Macbook Pro 2011. I have 19 hard drives in my photo archive and out of the 12 that are in different enclosures non have problems. USB 2/3, Firewire 800, even 2.5" drive attached to thunderbolt seagate dock: no issues.

    Had to spend $140+tax for what seems to be virtually the same box. Except USB 3 works.

    Tried to download the firmware update with the link you provided but it doesn't work.

Share This Page

10 February 1, 2013