OWC Mercury Elite Pro Enclosure USB 3.0 Sleep Issue

Discussion in 'Mac mini' started by Mojo1, Feb 6, 2013.

  1. Mojo1 macrumors 65816

    Joined:
    Jul 26, 2011
    #1
    I have two of these enclosures. When they are connected via USB 3.0 they do not spin down when the Mini is powered off. When connected via Firewire 800 they behave as expected: they spin down when the Mini is shut down.

    OWC provided a replacement enclosure and it does the same thing. OWC has not seen this problem with these enclosures that come with an installed drive. OWC also tried installing the same drive I use and it spins down. The drive in both enclosures is a 1TB Samsung.

    Has anyone else experienced this problem? I have read of similar problems with some other brands of external enclosures.

    Frankly, I can live with it: At the moment I have the enclosures connected via FW 800. If I elect to use USB 3.0 in the future I could simply turn them off manually. But I am hoping that the Macrumors "knowledge base" of users will have some suggestions about what is occurring and how I can fix this issue.
     
  2. JimT1701 macrumors member

    Joined:
    May 4, 2012
    Location:
    Massachusetts
    #2
    I use this enclosure with a WD 3TB Green Drive inside. I do not know if it is the drive or the enclosure doing this but the drive will spin down even with the Mini still running. I leave my Mini on 24/7 and usually in the morning I have to wait until the drive spins up again before I can access it. I also have a Newer Tech GuardianMaximus with 2 older Seagate 1TB drives with no "Green" features and even they will spin down and I do not think it is even designed to do that. I have drive spin down in System Preferences disabled. Anyway that is my experiences with Spin down and the Mini.
     
  3. kaibob macrumors regular

    Joined:
    Jun 21, 2010
    Location:
    Prescott, Arizona
    #3
    A month ago I purchased an OWC Mercury Elite Pro. It came preinstalled with a 1-TB drive, which I believe was made by Hitachi.

    I have encountered the exact same issue that the OP describes. With firewire, the drive immediately goes to sleep when I turn off my computer but does not when connected with usb 3.0. Once, when connected with usb 3.0, I waited about 30 minutes after turning off my computer but the OWC drive never went to sleep. I found this a bit odd, as the drive does go to sleep with usb 3.0 when the computer is running.

    My knowledge on this topic is quite limited and, unfortunately, I cannot suggest any fixes. I checked in system preferences and I do have a check mark next to the option to "put hard disks to sleep when possible."
     
  4. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #4
    Boy are you lucky @Mojo1, I think I can help!

    About 3 weeks ago I bought an OWC Express USB 3.0 external enclosure to house a 1 TB Hitachi hard drive that originally shipped with my 2012 Mac Mini (which I had replaced with an SSD).

    Every time my Mac woke from sleep, the drive had ejected itself, and hard. By that I mean that not even re-plugging the drive in would make the OS see it. I would have to do a full restart to have the OS recognize the drive. Something was seriously wrong.

    I reset the PRAM/NVRAM. Nothing changed.
    I reset the SMC. Nothing changed.
    I made sure the disk was healthy with Disk Utility. Was in perfect working order.
    I unchecked "Put hard disks to sleep when possible" in the Energy Saver preference pane. Didn't make a difference.

    I then said, "OK, just forget putting the Mac to sleep. Leave the thing on 24/7." And unbelievably, the OWC enclosure would still eject itself after a while!! This wasn't a sleep problem...

    The situation was ridiculous, especially considering that when I previously had this 1 TB drive connected "bare" with a USB 3.0-to-SATA adapter (which was separately powered, might I add), I never once had this issue.

    I called OWC and they RMA'd my enclosure for a replacement.

    I've had my replacement OWC Express for a few days now and I am happy to report that it no longer ejects itself and I don't have to restart my computer all the time or any of that nonsense. It seems that either the enclosure's controller or the USB 3 cable it shipped with was defective.

    If I somehow encounter problems again, my next strategy will be to buy a special USB Y-cable that plugs into 2 USB ports to draw all the power it needs. I'm fairly confident (and so is the OWC tech) that this is a USB power draw issue. The Mac's USB 3.0 ports are built exactly to spec, which means they won't give any extra juice if a third-party device asks for it (and many USB 3 devices do). This can lead to all sorts of wonky issues like the one I was previously experiencing. We'll see.

    So to recap:

    First suggestion: go through all the OS and firmware steps I described. Reset your PRAM/SMC/mess with energy settings.

    Second: RMA your drive and get a replacement.

    Third: try powering your drive separately / use a Y-cable (a.k.a. dual-head cable to draw extra power).

    Good luck!
     
  5. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #5
    Wow, I spoke too soon. My replacement OWC Express has not been any better than the last unfortunately. I'm getting the same problems.

    That means this is either a USB power issue or some kind of incompatibility with the controller. The smart money's on power draw.

    I've ordered a dual-head/Y-cable so my enclosure can draw more power if it wants. It should be here tomorrow or Monday. I'll report if it's working then.
     
  6. cosmicjoke macrumors 6502

    Joined:
    Oct 3, 2011
    Location:
    Portland, OR
    #6
    Sounds like incompatibility with the controller, that's a common issue with macs and JMicron Sata to Usb 3.0 controller as I understand it... but being from OWC, who specifically deals with mac users, you'd think they'd use something else...

    Actually, my bad, just woke up and see your problem is that you want them to spin down... the problem with the JMicron is they eject on spin down...
     
  7. dukee101, Feb 8, 2013
    Last edited: Feb 8, 2013

    dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #7
    Most OWC USB 3 external drives and enclosures use the ASMedia 1051e or 1053e controllers, not JMicron.
     
  8. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #8
    Update: I had some time to stop by my local Apple Store's Genius Bar and ask them about this issue. I explained everything that's described in this post (including my extensive troubleshooting) and the tech replied that this has not been reported as an issue across any of their Macs with USB 3 ports. Apple is unaware of any problem like this originating from their hardware.

    So this pretty much says it: we're dealing with a specific problem related to OWC enclosures and USB 3 Macs. Whether it be due to power or just some vague controller incompatibility, we'll find out soon enough!
     
  9. Mojo1, Feb 8, 2013
    Last edited: Feb 8, 2013

    Mojo1 thread starter macrumors 65816

    Joined:
    Jul 26, 2011
    #9
    Kaibob, I suggest that you contact OWC about your enclosure so they will know that you also have a sleep-related problem. I am working with OWC to see if we can determine the cause and they would probably like to know about other enclosures with the problem. It might help them to narrow-down the affected enclosures to a particular batch if it turns out to be a manufacturing defect.

    Both of my drives are Samsung. One was purchased over a year ago, probably from Newegg. The other is a newer Seagate/Samsung with the same model number that was purchased from OWC in December. I've been thinking that perhaps an internal drive setting might be the cause but your Hitachi drive certainly muddies the water in that respect... I suppose that it could be an OS bug but why would only some drive brands affected?

    As I have performed online searches regarding this matter I have stumbled upon other USB 3.0 external drive enclosure problems. But if I remember correctly they were all connected to Windows boxes. From what I understand there are Windows-only manufacturer drive utilities that make it possible to configure hard drive parameters that reside on the drives. Some of these settings affect drive sleep/hibernation. But I haven't come across similar utilities/settings for Macs.

    I wouldn't be surprised if we eventually find the cause. OWC has spent a lot of time with me and they seem to be determined to follow the trail to the end.

    As far as that Apple tech's statement goes: I would take it with a grain of salt.
     
  10. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #10
    You can't go by brand alone.

    If I read this thread correctly the drive was originally an internal drive which the OP moved to an OWC external drive case.

    The drive has Apple unique firmware, likely different from a retail drive.

    Apple spec'ed the drive to work as an internal. Not as an external behind a USB bridge chip.

    Not all drive firmware is necessarily compatible for this application.

    Or the JMicron doesn't know how to live with the unique Apple firmware.
     
  11. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #11
    I want to stress again that prior to using an OWC enclosure, I've had this same drive hooked up with another USB 3 adapter and it worked for over two weeks without a single hiccup. The difference? It was powered through a separate AC/DC power adapter. Give me a few days and I will hopefully prove this (power) is the culprit here.

    The odds of that are extremely low. I've pulled out countless stock Apple hard drives from Macs before to use elsewhere and there is no such custom firmware on them. I've pulled out Hitachi, Seagate, and Toshiba drives throughout the years and I've never thought twice about using them elsewhere (in other computers, in external enclosures, etc).

    Again, OWC doesn't use JMicron in their USB 3-based hardware. For the OWC Express and similar enclosures, they use the ASMedia 1051e and 1053e controller chipset. For the OWC Mercury Elite Pro, they use the Oxford 944 and Oxford 3100 controller chipsets. See the SPECS tab on this page. No JMicron to speak of.
     
  12. elolaugesen macrumors regular

    Joined:
    Aug 1, 2008
    #12
    look at this thread a couple of entries on in this forum
    2012 Mac Mini not charging iPad 4

    cheers elo
     
  13. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #13
    Good points all. So a combination of factors leading to a perfect storm of "not working".

    By custom firmware, I mean that there is unique identification that Apple may include; sometimes as simple as an Apple specific label, to actual firmware functionality differences.

    I am familiar with the ASMedia chipsets, as well as different firmware versions used by different case vendors. Yes, could be something as simple as older firmware in the OWC cases. ASMedia seems to have different versions out in the wild; perhaps to correct different issues with specific drives.

    I hope you are able to discover the cause of the issue and correct it.

     
  14. Mojo1 thread starter macrumors 65816

    Joined:
    Jul 26, 2011
    #14
    That is incorrect. The drives used in my external enclosures were not internal drives. One was used in a NewerTech enclosure and the other one was purchased from OWC and I installed it myself.

    The Mercury Elite Pro enclosures make it very easy to do the installation yourself. Instead of having separate data and power plugs that must be plugged into the drive all it takes is sliding the drive until the two ports connect. Most enclosures require connecting separate plugs on the end of small cables. Making things fit correctly usually requires doing some bending of the cables when you put the enclosure together. It can be a tight fit... The MEP has two external screws and four internal screws; figure about five minutes start to finish when installing a drive.
     
  15. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #15
    I have a very unfortunate update on the situation: I've had a dual-head USB 3 cable for 2 days now and I'm still getting the ejects. Despite being driven by the power of 2 USB ports, the drive still ejects after sleep.

    I'm officially ruling this an incompatibility between OWC's enclosure and my Mac. Case closed. Drive will be RMA'd for a refund and I will go about having to buy a new external solution.
     
  16. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #16
    "I'm officially ruling this an incompatibility between OWC's enclosure and my Mac. Case closed. Drive will be RMA'd for a refund and I will go about having to buy a new external solution."

    I, too, have had compatibility problems with external USB devices purchased from Other World Computing.

    In my case, it was an early version of the "Voyager Quad" USB3/Firewire/SATA docking station. It only works at USB2 speeds when connected to my 2012 Mac Mini. I'm guessing it's an incompatibility with the controller chip used in the docking station.

    If you get the RIGHT USB3/SATA enclosure or docking station, you may be relieved of these problems.

    The controller chips to look for are the
    - ASMedia 1051e
    - ASMedia 1053

    Here are three products that have one of the above:
    http://oyendigital.com/hard-drives/store/U32-M.html
    or
    http://www.amazon.com/dp/B00APP6694...=2025&creative=165953&creativeASIN=B00APP6694
    or
    http://www.amazon.com/Plugable-Dock...=2025&creative=165953&creativeASIN=B003UI62AG

    I have the plugable.com "lay-flat" USB3/SATA dock which I use with an Intel 520 series SSD. No sleep issues or random disconnects, and it yields read speeds of 410mbps and write speeds of 247mbps. Not bad for $30...
     
  17. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #17
    The OWC Express enclosure I have has the ASMedia 1053e controller. I'm not sure if being the "e" model as opposed to the "regular" model you mention makes a difference but given my experience: probably.

    Thanks for the other suggestions though.
     
  18. glitch44 macrumors 65816

    Joined:
    Feb 28, 2006
    #18
    Anyone have problems with the Newertech Guardian MAXimus Enclosure (also sold by OWC)?

    http://eshop.macsales.com/shop/firewire/usb/raid_1/Gmax

    Its chipset is listed as "Custom Oxford 946 eSATA, FW400(1394A), FW800(1394B), and Ox3100 USB 3.0 Integrated Chipset" so I suspect it might be susceptible to the same incompatibility, but I wanted to ask here first.
     
  19. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #19
    Also a function of the ASMedia firmware that is loaded. Perhaps OWC can confirm the firmware version. they may be out of date.
     
  20. glitch44 macrumors 65816

    Joined:
    Feb 28, 2006
    #20
    So any updates on this situation or any suitable alternatives to the effected models?
     
  21. Mojo1 thread starter macrumors 65816

    Joined:
    Jul 26, 2011
    #21
    OWC Update...

    A few days ago I received the following message from my OWC tech contact:

    "When we tested the enclosure that you returned, we actually experienced the same issue using our own test drive. We have the issue assigned to our product development team to look into, but at this time there are quite a few projects ahead of it, so it may be over a week before we have a resolution."

    The replacement enclosure that I received around a week ago has the same problem so it will be interesting to hear what OWC comes up with during their investigation of the problem.
     
  22. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #22
    Absolutely. Thanks for updating us Mojo1. Looking forward to what OWC's tech team has to say about this.

    As an aside: I've bought an HGST Touro Mobile Pro 1 TB USB 3 portable hard drive to see how this solution works out. I'll update here if it's stable for a week or more.
     
  23. dukee101 macrumors member

    dukee101

    Joined:
    Jan 17, 2009
    #23
    In a final update on this issue, I've been running my HGST 2.5" USB 3 portable external for a while now with no problems whatsoever. This isn't an issue with the Mac mini having under-powered USB ports. No, this is an issue with OWC's external enclosures. Case closed.
     
  24. FireWire2, Feb 22, 2013
    Last edited: Aug 22, 2013

    FireWire2 macrumors 6502

    FireWire2

    Joined:
    Oct 12, 2008
    #24
    Keep USB spining

    Or you can go to Datoptic.com
    USB3.0 to eSATA adapter support Port Multiplier

    Go to SUPPORT TAB - look at the last Q&A - download and install the app

    Your USB drive wont drop off anymore
     
  25. BJonson macrumors 6502a

    BJonson

    Joined:
    Aug 26, 2010
    #25
    I have had a problem with every single drive enclosure I have ever bought from OWC. For some dumb reason their chipsets are not mac compatible. Go figure. The products I have bought have been Newer Technology products though so maybe they just suck but OWC needs some of that hate because they keep selling them.
     

Share This Page