OWC SSD Firmware Update trouble on iMac 9,1

Discussion in 'iMac' started by Morten Nielsen, Feb 18, 2014.

  1. Morten Nielsen macrumors newbie

    Joined:
    Feb 18, 2014
    #1
    Hi there.

    My OWC Mercury Electra 3G SSD was sold with the 507ABBF0 firmware, so I'm trying to upgrade to 522ABBF0. Given that my Mac is an early 2009 model (iMac9,1), I have to use the old DVD-based updater. The SSD is mounted via a Data Doubler kit in place of the Superdrive, acting in tandem with the HDD as a DIY Fusion Drive, so to burn and boot a DVD with the firmware updater software, I had to put the Superdrive back and temporarily arrange for the SSD to take the HDD's place on the main SATA cable.

    Ok. This worked out well (apart from a great number of various error messages during DVD boot) as far as to the software detecting my SSD and recognizing that it needs an update, but then I get the error message "Sorry, the firmware file appears to be damaged". I retried, downloaded the image again, checked the MD5, burned it again to a fresh DVD with verification. Same story.

    Then in desperation I also tried the USB-based updater, even though it doesn't fit my iMac model. I tried a few "close" models from the selection screen, got to the same updater GUI, and got the exact same error message again.

    I took some photo screenshots during the operation, check out https://www.dropbox.com/sh/52b9195qegmi9rp/rT17MvaFd2

    I've written the OWC helpdesk, but they haven't replied yet. Anyone care to share any tips or thoughts?

    Kindly
    Morten
     
  2. macthefork macrumors 6502

    Joined:
    Feb 2, 2013
    #2
    OWC technical support is very good about responding, so give them time. I had a very similar problem applying their update to a OWC SSD drive. In my case, it would recognize the drive as needing the update, but then, when I went to apply it it would say that no OWC drives were found.

    After long communications back and forth through emails with OWC, I finally ended up shipping the SSD drive back to them under warranty for them to either replace or update the drive.

    They did update it, and I received it back in good working order. By then, I'd replaced it with a Crucial M500 in the iMac, and put the OWC drive in a HP Laptop, where it's much easier to reach if it needs updating in the future.
     
  3. Morten Nielsen thread starter macrumors newbie

    Joined:
    Feb 18, 2014
    #3
    Thanks for replying. I got an answer from OWC, but they seem to just have given up and want me to send the drive to them for updating. That is an option I would really want to avoid, seeing as I now use the SSD for my main computer, and I live in Denmark, so there's an issue with customs and delays.

    I'm now looking into using Boot Camp for the update. OWC states on their webpage: "SSD must either be initialized with an MBR partition table or have a Windows partition applied through Apple's Boot Camp Assistant". Does anyone know if it would be sufficient to create a hybrid MBR using, say, gdisk?
     
  4. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    I suspect people will refer you right back to OWC tech support for the answer to that question.
     
  5. Morten Nielsen thread starter macrumors newbie

    Joined:
    Feb 18, 2014
    #5
    In the end and after a lot of frustrations and dead ends I managed to get my firmware update done in my own home. I used gdisk to create a hybrid MBR for my SSD, and booted from a Hiren's Boot CD (15.1, not 15.2 which has a menu keyboard bug) into a mini Windows XP that lets you run the firmware installer from a USB stick!
     

Share This Page