OWC Thunderbolt 2 Dock, MBP13 won't stay asleep

Discussion in 'Mac Accessories' started by esskay, Dec 2, 2015.

  1. esskay macrumors 6502

    Joined:
    Jan 3, 2008
    #1
    Howdy folks,
    I just got an OWC Thunderbolt 2 Dock for my early 2011 MBP13 (i7, SSD). I use it in clamshell mode on my desk, connected to a monitor, ethernet, speakers, and 3 USB items (DAS keyboard, MSFT trackball, and Fujitsu ix500 scanner). I'm running Yosemite OS X 10.10.5.

    It works great in operation... but when I put the MBP to sleep, as soon as the machine goes to sleep (noted by the status LED finally going dark, and which by the way takes quite a while in part due I'm sure to saving the 16GB of RAM), it immediately wakes back up.

    I googled a little bit but couldn't find anything specific. I've tried turning off bluetooth, using a USB hub vs directly connecting the USB items, connecting the monitor via HDMI and via Thunderbolt (display port adapter). No matter these combinations, every time I put the laptop to sleep, it immediately wakes back up.

    I haven't yet tried disconnecting my USB peripherals, but if I can't sleep the machine with my keyboard, trackball, or scanner attached to my dock, that's just absurd.

    It defeats the whole purpose of the dock if I have to unplug it to allow my MBP to sleep while sitting on my desk.

    Has anyone experienced this problem? Does anyone have any suggestions or solutions for this? Thanks in advance!
     
  2. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #2
    My rMBP sleeps well even with two docks attached (not OWC branded).

    You may want to look at some of the insomnia threads. There is guidance to what to look for in the system log, look for entries that may give you a clue what is waking the machine up. I know if someone connects or disconnects a USB device connected to a dock when the machine is sleeping, its going to promptly wake up.

    You may want to talk to OWC support as it could be a failure mode of their dock.

    Good luck as insomnia can be frustrating to track down.
     
  3. esskay thread starter macrumors 6502

    Joined:
    Jan 3, 2008
    #3
    Thanks for the suggestions! I found a discussion on the pmset -g assertions command.

    I had a bunch of garbage in mine (below).

    I figured I hadn't rebooted my machine in a while, and certainly not since I installed the Thunderbolt dock. So I shut down, restarted, and lo and behold my pmset -g assertions is completely empty now, and I was able to put the machine to sleep. Not sure why my system got so buggered up but rebooting seems to have helped.

    Thanks again.

    >>>>>>
    pmset -g assertions
    2015-12-02 19:36:48 -0800
    Assertion status system-wide:
    BackgroundTask 1
    ApplePushServiceTask 0
    UserIsActive 0
    PreventUserIdleDisplaySleep 0
    PreventSystemSleep 0
    ExternalMedia 0
    PreventUserIdleSystemSleep 1
    NetworkClientActive 0
    InternalPreventSleep 1
    Listed by owning process:
    pid 241(UserEventAgent): [0x00035757000b283c] 00:00:23 BackgroundTask named: "com.apple.AddressBook.ScheduledSync"
    Created for PID: 15406.
    pid 15406(AddressBookSour): [0x0003574200012825] 00:00:44 PreventUserIdleSystemSleep named: "Address Book Source Sync"
    Timeout will fire in 1756 secs Action=TimeoutActionTurnOff
    pid 359(Google Chrome): [0x00021168000104eb] 50:00:46 NoIdleSleepAssertion named: "WebRTC has active PeerConnections"
    pid 51(powerd): [0x00035755000d282a] 00:00:24 InternalPreventSleep named: "com.apple.powermanagement.acwakelinger"
    Timeout will fire in 20 secs Action=TimeoutActionRelease
    Kernel Assertions: 0x24=USB,THNDR
    id=502 level=255 0x20=THNDR mod=12/2/15, 19:49 description=NHI0 owner=AppleThunderboltHAL
    id=751 level=255 0x4=USB mod=12/2/15, 19:46 description=pci1b73,1100 owner=AppleUSBXHCI
    id=752 level=255 0x4=USB mod=12/2/15, 19:45 description=pci1b73,1100 owner=AppleUSBXHCI
     
  4. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
  5. esskay thread starter macrumors 6502

    Joined:
    Jan 3, 2008
    #5
    Just closing the loop on this problem for anyone who might find it on Google/etc.

    I had continuing problems with the OWC dock causing my MBP13 to be unable to go to sleep.

    I finally discovered the golden setting which solved the problem.

    In Energy Saver in System Preferences, uncheck the option called "Wake for network access."

    Once I did that, all was good again, and the OWC dock is otherwise working great!
     

Share This Page