jsgrabo

macrumors regular
Original poster
Feb 12, 2007
147
0
on my brothers macbook (2.1ghz 10.5.5) the "p" stopped working when he booted it up this morning. if you hold shift and then hit "p" you get a capital P as usual. if you hit command p, you get printing. when you just "p" by itself, nothing happens/types. he says it worked fine last night and then when he turned it on today, it did not work. i'd appreciate any tips/help. thanks!
 

xUKHCx

Administrator emeritus
Jan 15, 2006
12,583
7
The Kop
That is a rather odd problem. In terms of a solution I am not so sure. Perhaps you could try reseting the PRAM , to do this press cmd+option+p+r on boot. Of this might not work if the computer doesn't recognise the p button at that stage of the boot process.

You may also try to Safe Boot, pressing shift on boot then let the computer fully load and restart normally.

Also might be worth seeing if it is the same with a separate account on the same computer.
 

Andersand

macrumors newbie
Jan 15, 2012
1
0
Solution for non functional p key

After a clean reinstall of snow leopard and resetting pram my p still didnt work....

I noticed that also caps lock wasn't working properly so after reading someone else posting somewhere that turning on caps lock and putting the computer to sleep would reactivate the caps lock keys function I thought it worth a try.

It worked!

I simply held down the caps lock key while putting it to sleep via the menu and when it was a sleep I woke it up again and magically the caps lock led was on and both the p and the caps lock key worked again..... Why this worked I have no idea.... It must be a bug.

I hope this helps someone else prevent an unnecessary keyboard replacement... I almost sent mine for service....
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.