PackageMaker not installing app

Discussion in 'Mac Programming' started by john903, Jul 5, 2008.

  1. john903 macrumors member

    Joined:
    Apr 11, 2008
    #1
    I created a new installer using PackageMaker. The installer seems fine but after going through the installation process it doesn't install the application. I've double checked the package contents to make sure all the correct files are there. Is there an error log somewhere I can check?
     
  2. iSee macrumors 68040

    iSee

    Joined:
    Oct 25, 2004
    #2
    There is a log.
    Run through the install until you get to the last screen. Don't close it, though. Look in the menu for the Log window (I think it's under the Window menu). You can set the level of detail you want to see--try changing that if you can't see where the error is. If there's no error, I'd guess the files are getting installed but not where you are expecting.
     
  3. john903 thread starter macrumors member

    Joined:
    Apr 11, 2008
    #3
    Thanks! This is the error I'm getting.

    Jul 6 12:28:33 72-28-223-169-dhcp Installer[194]: Package Authoring Error: Results of component search (com.MyCompany.MyProduct) not usable by package.
     
  4. john903 thread starter macrumors member

    Joined:
    Apr 11, 2008
    #4
    I just tried a very simple example that didn't work. I created a blank Cocoa application, compiled it and then created an installer for it with PackageMaker.

    This one doesn't give any errors but the application is no where to be found. The only difference between now and when I've done this in the past is the 10.5.4 update. :(
     
  5. john903 thread starter macrumors member

    Joined:
    Apr 11, 2008
    #5
    Could someone try these steps on Mac OS X 10.5.4 and see if you have the same problem? Here are my exact steps to make the simplest installer possible.

    1) Create a new Cocoa application called EmptyApp and make a release build.

    2) Open PackageMaker and make a new package with 10.3 minimum target and com.MyCompany for organization.

    3) Drag the release build of EmptyApp into PackageMaker.

    4) Click "Build and Run" and go through the installer. The application for me is not installed and there are no error messages.

    Thanks!
     
  6. john903 thread starter macrumors member

    Joined:
    Apr 11, 2008
    #6
    I found the problem but I don't understand why it's fixed. I deselected Allow Relocation in the Components section for the application and the installer works now. :) What does that option do? I couldn't find any references to it in the documentation.
     
  7. iSee macrumors 68040

    iSee

    Joined:
    Oct 25, 2004
    #7
    I think the behavior you are seeing is correct.
    When "allow relocation" is checked it means that the installer will search for an existing copy of the application and replace it there rather than the default install location. It's probably finding the app in its build folder and replacing it there.

    This option allows an update to work, even if the user has moved the application since being installed. For example:
    1. User installs SomeApp version 1.0 at /Applications/
    2. User moves SomeApp to /SomeOtherPlace/
    3. User installs SomeApp version 1.1.

    With "allow relocation" checked, SomeApp version 1.1 will replace SomeApp version 1.0 at /SomeOtherPlace/.
    If "allow relocation" is not checked, SomeApp version 1.1 will be installed to /Applications/, leaving two copies of the app installed (version 1.0 at /SomeOtherPlace/ and version 1.1 at /Applications/).

    This is briefly mentioned in the latest docs (not quite by name, which might be why you missed it): http://developer.apple.com/document...doc/uid/TP40005371-CH1000-DontLinkElementID_8
     

Share This Page