Pages 09' Spell Check Problem

Discussion in 'Mac Apps and Mac App Store' started by GovtLawyer, Mar 13, 2011.

  1. GovtLawyer macrumors 6502

    Joined:
    Sep 6, 2008
    #1
    I use Pages 09' on my 2008 iMac. Up until yesterday it has worked flawlessly. The problem is that I seem to have lost the Spell Checker when working on documents saved in My Templates.

    For example, I open up a template of my business letterhead and start to write a new letter. The Spell Check is non-existent and will not work when selected from the menu bar. If I open up a blank document and begin to write the same letter, the Spell Check works. As I type this, the Spell Check is catching my errors and it does so in all applications where I have always expected it to work.

    I have not made any changes to my operating system (Snow Leopard) or anything else on my computer. I have shut down and restarted the computer to no avail. This cropped up yesterday without warning.

    Any suggestions?
     
  2. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #2
    When an application that was working correctly stops doing so, the most common cause is corrupt preferences. Go to HD > Users > (your account) > Library > Preferences, delete the com.apple.iwork.pages.plist, empty the Trash & then restart Pages.
     
  3. GovtLawyer thread starter macrumors 6502

    Joined:
    Sep 6, 2008
    #3
    I Tried. Not Quite There Yet!

    I followed the directions regarding the plist and restarted Pages. It still didn't work. I went through all of the preferences and made sure they were how I wanted things corrected, etc. I then was able to have the Spell check and auto capitalization as I work on a blank document, but not on a template.

    I went back and forth between the different type of documents, including cutting and pasting text which had been flagged as wrong in the blank document, into a template. After repeated efforts the Spell Check suddenly started to work again.

    So, what I have seems to work, but is buggy. Could it be the Spell Checker module, or whatever, as opposed to Pages?
     
  4. GovtLawyer thread starter macrumors 6502

    Joined:
    Sep 6, 2008
    #4
    Its The Templates

    I went back and discovered that the problem appears to involve MY TEMPLATES, but not all of them. For example, typing incorrectly on my Letterhead Template does not get corrected, or even flagged. Typing incorrectly on my Envelope Letterhead Template does get caught.

    I made all of the templates a year ago, and all of them worked just fine until yesterday, and now some of them can get spell checked. I'm stymied by this. Any other ideas?
     

Share This Page