Pages '09 UK Spellcheck?

Discussion in 'Mac Apps and Mac App Store' started by Hammy :), Oct 13, 2009.

  1. Hammy :) macrumors newbie

    Hammy :)

    Joined:
    Aug 29, 2009
    Location:
    Leeds, England
    #1
    Hi all, I'm new to using pages. I've always used MS word on my macs.

    However im from the UK and im doing some English GCSE coursework.

    I noticed, however that when i typed the word 'neighbour' (which is the correct UK spelling) pages said that i spelt it wrong and gave me the US spelling which is 'neighbor'

    I checked my System Pref. and I have all my language settings set to English (UK)

    Can anyone help me set the spellcheck to be british, as during coursework, this sometimes throws me off quite a bit.

    thanks :)
     
  2. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #2
    I don't use Pages, I use Word. However, I'm just wondering if there's a setting in Pages for a custom or default dictionary. If there is, you may need to set the default language to English UK rather than English US.
     
  3. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #3
    I have always wondered why it does this, and could not find a way around it. I now type the word as it is meant to be spelt and click learn spelling, then next time it also knows the English version of the word.
     
  4. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #4
    I believe Pages uses the system default.

    System Preferences - Language & Text - Language - Edit List

    Tick British English and drag it to the top of the list.


    Also confirm that under the "System Preferences - Language & Text - Text" tab that British English is listed.


    There was a trick pre Snow Leopard or whatever version of Pages that I currently have where by you would change the Language inside TextEdit spelling options to British English but it seems to follow the system now.
     
  5. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #5
    That didn't work for me.

    I cured it by opening a new document, clicking on Inspector / T / More / Language and picking British English. Close Inspector and save the document as a template.

    Go to Pages / Preferences and select your new template under For New Documents.
     
  6. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #6
    If you had Pages open at the time it doesn't take effect until you restart it.

    Pages spell check follows the system default as it was when the program was started. At least with Snow Leopard and iWork 09.
     
  7. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #7
    It makes no difference on mine (Snow Leopard & iWork '09). Even after restarting Pages it still uses the US dictionary if I create a new document with one of the standard blank page templates.

    When I use my template I've got the British dictionary. :confused:
     
  8. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #8
    Are you changing the System Preferences - Language & Text - Language order? If I change mine and start Pages it will follow the system default. For example putting it in French it starts up spell checking french, although it also changes the menus to be in french.

    I didn't have to set any templates but if it is a work around for a possible bug then it is always handy to know. :)
     
  9. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #9
    I know what I was doing wrong now.

    I had just changed the preference for Text / Spelling to British English. It's working properly now I've added Language / British English. :eek:

    I've never had to fuss about like this with Word. ;)
     
  10. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #10
    Indeed, you would think apple would've set Snow Leopard (and all other versions of OS X because it really isn't that hard) up that if you say you are fron England that it uses British English or as it is known English. This is a common cause of confusion for British people as we speak English so when we see it set up as English we assume it is the correct English but it is not.
     
  11. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #11
    And it costs us more for the privilege. :D
     
  12. Hammy :) thread starter macrumors newbie

    Hammy :)

    Joined:
    Aug 29, 2009
    Location:
    Leeds, England
    #12
    ah thanks alot xUKHCx

    this worked for me :)

    PS apollo creed OWNS
     

Share This Page