Pages/iWorks won't open error message.

Discussion in 'Mac Apps and Mac App Store' started by Timea, Mar 19, 2012.

  1. Timea macrumors newbie

    Mar 18, 2011
    I need some help. iWorks, pages, keynote, numbers won't open. The little icon bounces for a long time then I get an error message.

    I did the permission thing, I did remove and re install the program and it still not working.

    I am running snow leopard and my current OS is 10.6.8

    Can any of you help me, please. Thank you

    Attached Files:

  2. snberk103 macrumors 603

    Oct 22, 2007
    An Island in the Salish Sea
    I assume you have restarted the system? If not, that's your first step.

    Is this an existing installation, or did you just install it (or upgrade it)? If it's been just installed then install it again. If it's a pirated version, buy and install a legitimate version. If it's an old installation, and if you haven't installed much of anything else, then it's probably HW related.

    Have you recently add RAM? If so, remove and put the original back to see if the problem persists.

    If you are using the original/old RAM, and have more than one stick of RAM, remove one to see if the problem persists. If so, swap the other stick in. If/when the problem disappears, the stick(s) of RAM in your hand is the culprit. NOTE: If you do not know how to remove/swap RAM please do some research first. It's not hard to do (unless you have an old Mini) - but you do need to do properly.

    If you can eliminate RAM, then a flaky HDD may be the culprit. Research how to test your specific HDD and model of Mac.

    If that doesn't help.... then you have something very specifically wrong with the system, and is beyond my help. Luck.
  3. Timea thread starter macrumors newbie

    Mar 18, 2011
    Yes, I have restarted the computer many times. This is a new problem for an old program. I have been using Pages daily and yesterday it just won't open. I have done nothing new to the computer other than turned on the firewall. As I said I removed the program and re-installed and re-strated the computer again and still not working.
    I have a Macbook.

    What is "HW"?

    Thank you
    PS: Sorry for the duplicate post I did not see the first one posted.
  4. snberk103 macrumors 603

    Oct 22, 2007
    An Island in the Salish Sea
    HW = Hardware

    I missed the part where you said you had already re-installed - sorry.

    Try turning the firewall off. It shouldn't make a difference, but if that was the only change then it's worth trying.

    Generally speaking.... and there are exceptions..... problems that are sporadic or that pop up suddenly on their own tend to be hardware related.

    However, this this problem seems to be iWork only related.... makes me think it's SW (Software related). Have you given the applications a good workout?

    Why did you turn the firewall on at this time?
  5. djarmiac macrumors newbie

    Nov 21, 2012

    I am having the same problem. How do I fix this. I need to access my spreadsheets :(
  6. skotta macrumors newbie

    Dec 24, 2012
    iwork numbers, pages and Keynote dont start

    I am having the same problem as noted above.
    I am using OSX10.6.8.
    Problem started when i removed numbers and reinstalled it. initially only numbers was not working. I tried to remove whole iwork ad reinstall. since then all the components stopped working.
    I get the same message as the first post and app would not start. please help.
  7. skotta macrumors newbie

    Dec 24, 2012

    I have sorted the problem.

    I installed iwork update9.1 from apple download site and then reinstalled iwork09. every thing works normally now!!
  8. palmharbor macrumors 6502

    Jul 31, 2007
    same problem

    I had the same problem running10.8.2 after the recent pages update.
    I re-installed it from the DVD took an update and now it works fine.
  9. colourfastt macrumors 6502a


    Apr 7, 2009
    Apple: it used to just work in the past.

Share This Page