Pages: Pop up warning about missing font even after I've removed all of that font

Discussion in 'Mac Apps and Mac App Store' started by RandomHavoc, May 9, 2014.

  1. RandomHavoc macrumors member

    Joined:
    May 26, 2010
    #1
    In my office I'm the only one that uses Mac. So I often get files from people that I need to modify. So what's happening a lot now is when I open the files I always get a pop up saying "The font Calibri is missing. Your text might look different".

    It's really starting to irritate me so I went through a few documents (which are small, often just one page) and have tried to systematically make sure there's not a single word of text I haven't manually changed to Helvetica. Doesn't matter. Stupid pop up still happens every time I open them. Even when I've done Command A both in and out of the table on the documents.

    Thanks in advance.
     
  2. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #2
    A common problem. For some reason Word embeds Calibri in virtually every document, even when it isn't used anywhere in the document. The way to fix this is to substitute another font for Calibri. Select the "missing font" in the warning dialog box and from the popup list pick another font (the one used for the body of the document).
     
  3. RandomHavoc thread starter macrumors member

    Joined:
    May 26, 2010
    #3
    Unfortunately it's not so easy for me. There's nothing in the dialogue box to click on to substitute another font in, and when I manually select all the text and change the font the pop up still keeps happening.
    The only thing I can click in the pop up box is to not warn about this document again but that doesn't fix it when I open that file on my other Mac or on my iPad (which doesn't even give me THAT options. There's absolutely nothing for me to click in the pop up box on the iPad's Pages app).

    Any other ideas?
    A simple way to find and substitute the Calibri font would be perfect but I can't find a way to do that.
     
  4. ricosuave macrumors 6502

    ricosuave

    Joined:
    Mar 27, 2007
    Location:
    In front of my mac
    #4
    You can go onto Microsoft's site and download the office fonts for free. After I did that, the warnings stopped in Pages.
     
  5. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #5
    Possibly Apple deleted this option in Pages 6, but the substitution is certainly available in the previous version. If that is the case, it seems you will have to try the other advice and install the font.
     
  6. HelenaH macrumors newbie

    Joined:
    Nov 11, 2014
    #6
    Hide warnings

    Hi there,
    I've had the same problem and it's really annoying! I found that there's an easy way to get rid of this, though. Just click View and then Hide warnings, and all those popup windows go away :)
     

Share This Page