Pages spell-checker?

Discussion in 'Mac Apps and Mac App Store' started by nicoleasks, Nov 16, 2011.

  1. nicoleasks macrumors newbie

    Joined:
    Sep 30, 2011
    #1
    Little help?!

    The spell-check was working fine before today, but today it isn't working at all - not the "check spelling while typing" function (yes, it IS selected under Edit > Spelling), and not even the spellcheck window: it opens fine, but it doesn't recognize any errors when there definitely are some.

    Did I inadvertently change my settings or something? What's wrong?

    Thanks for your help!!
     
  2. finalcutproFCP macrumors newbie

    Joined:
    Apr 5, 2010
    #2
    The same thing happened to me. I was working an a very important document that had to be done by the next day so I was forced to use word. Then the next day without thinking I opened up pages and BOOM, it works.

    I have no idea what happened
     
  3. nicoleasks thread starter macrumors newbie

    Joined:
    Sep 30, 2011
    #3
    Yeah, mine started working again last night.

    Does anyone know why this happened, so we can avoid it in the future (if possible)??
     
  4. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #4
    The most common cause for spell checking to stop working is corrupt preferences. Go to HD > Users > (your account) > Library > Preferences, delete the com.apple.iwork.pages.plist & restart Pages. If you're using Lion, hold down the Option key in Finder while clicking the Go menu to reveal your user library.

    Another cause that affects users not using US/North American English is setting the language for the paragraph style in the text inspector > More > Language. By default it is set to "English" which is "US English."
     
  5. nicoleasks thread starter macrumors newbie

    Joined:
    Sep 30, 2011
    #5
    Thanks, Peggy. Will deleting the preferences also delete all my auto-correction words?
     
  6. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #6
    I'm not sure where the auto-correct words are stored. You could move the plist to the desktop & then restart Pages & check.
     

Share This Page