Panther & Nikon Capture NX 2

Discussion in 'Mac Apps and Mac App Store' started by Rhobes, Oct 6, 2008.

  1. Rhobes macrumors 6502

    Rhobes

    Joined:
    Oct 28, 2004
    Location:
    Missoula,MT
    #1
    Hi All-

    I have 10.3.9 and want to buy the Nikon Capture NX2 editing software for my D300 camera. System requirements state: 10.4.11 for the software. My computer has been upgraded as in my signature, I'm wondering if it could work with what I have? What does 10.4 have that leaves Panther out? :confused:
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    The software is a free download. You can try before you buy.
     
  3. Rhobes thread starter macrumors 6502

    Rhobes

    Joined:
    Oct 28, 2004
    Location:
    Missoula,MT
    #3
    Thats right, I'll see if it will download first....
    Thanks-
     

Share This Page