Panther Safari (1.3.2) crashing on Google Maps

Discussion in 'Mac Apps and Mac App Store' started by Makosuke, Apr 28, 2008.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    A friend asked me to see if I could figure out why her Panther Safari install (fully updated 10.3.9, Safari 1.3.2) was crashing when it attempted to load Google Maps.

    Indeed it was (unexpected quit as it tries to load the main Google Maps page or any page with a Google map embedded in it), and it kinda stumped me, nor did Google provide any help in a bit of searching.

    Anybody seen this issue, or have a suggestion? I installed Camino as a workaround, which is fine, but I hate to walk away from things unsolved, and I tried everything I could think of short of a full reinstall of the OS:

    * It DOES crash even on a newly-created user, so it's not prefs.

    * I tried reinstalling the 10.3.9 combo updater.

    * The Safari install was also having the no localized string problem, so I did the recommended solution: Delete Safari and the webkit framework, install the Safari 1.2 download, reinstall (again) the 10.3.9 combo updater, then run the 1.3.1 and 1.3.2 Safari updaters. This DID fix the strings issue, but did not help with the crashing.

    Interestingly, while I was doing that I noticed that Safari 1.2 did NOT crash on Google Maps (but started to again after the 1.3 update). What the heck is up with that?
  2. Anodizer macrumors newbie

    Sep 5, 2008
    Safari Crashing

    I have had the same problem for some time know. Google maps always worked fine for me until sometime around April. I am not computer savy, however looking for some help. Ihave also had Safari crash on several other sites.
  3. KDons macrumors newbie

    Sep 11, 2008
    My Safari 1.3.2 also crashes on Google maps, probably starting about the same time. It also crashes on Mapquest so I have resorted to Rand McNally which works fine. Have you found a different solution?

Share This Page