Parallels 4 Desktop on a Mac Mini 2010

Discussion in 'Mac Apps and Mac App Store' started by ewoks, Sep 26, 2011.

  1. ewoks macrumors newbie

    Joined:
    Sep 26, 2011
    #1
    Hi there everyone :) We have this Mac Mini 2010 and I tried to install Parallels Desktop 4 for Mac. The problem is during installation Parallels is saying that it cannot proceed with the installation because our Mac Mini is not intel-based :(, which is kinda weird. I would appreciate any comments to resolve this issue. Thanks!
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    Your copy of Parallels is too old and 4 is no longer supported. Check here to be sure you have the latest version of PD 4, it may solve your problem:
    http://kb.parallels.com/5802
     

Share This Page