Parallels 7 Not working after Upgrade to Mnt. Lion

Discussion in 'Mac Apps and Mac App Store' started by DirtyD1985, Jul 31, 2012.

  1. DirtyD1985 macrumors newbie

    Joined:
    Jul 31, 2012
    #1
    Hello :apple: Everyone,

    Yesterday night I upgraded to Mnt. Lion and like a noob I forgot to update Parallels 7 for my Late 2008 MBP first. Now parallels is saying "not compatipable" when I try to start it up. Does anyone know of a way to update Parallels to work on Mnt. Lion without reinstalling either programs?:confused:
     
  2. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
  3. Bobby.e macrumors 6502

    Joined:
    Mar 11, 2012
    Location:
    Kansas
    #3
    As the person above me said. There is an update out for Parallels. You just need to download and install that.
     
  4. ramases macrumors member

    Joined:
    Jan 14, 2008
    #4
    You need to follow the instructions on the parallels support page below

    http://kb.parallels.com/114449

    you will need to re-install the Desktop app (305Mb download)
     
  5. DirtyD1985 thread starter macrumors newbie

    Joined:
    Jul 31, 2012
    #5
    Does anyone have a link to the update / know how to perform it? I cannot even start up Parallels, and the company website does not seem to help, unless I am doing something wrong?

    ----------

    Understood thank you for the assistance !:)
     
  6. jkeekij macrumors regular

    Joined:
    Oct 17, 2011
    #6
    There is a link in post #4 and once that link is followed you will find instructions and the download.
     
  7. crashdebris macrumors newbie

    Joined:
    Jul 5, 2011
    Location:
    Boomer! Sooner!
    #8
    version 6 user

    I am a user of version 6. It is NOT being supported in Mountain Lion. I bought ver 6 after the start of an 8 week semester and ver 7 came out before end of semester, I was a bit mad when I was not offered a free upgrade at the time. I chaulked it up to unfortunate timing and went on with life. I needed the software when I bought it and it has worked flawlessly on lion.

    I then decided to upgrade my systems to mountain lion. I did my older iMac first, I can afford to be without it since it is not my main school machine (online school). Everything went well so i decided to upgrade my Macbook Pro, which IS my main school machine. After it completes I find out about parallels 6 not being supported. I have a class starting in a couple weeks that requires windows so I am stuck.

    I REALLY don't want to give parallels $50 to upgrade when ver 6 worked perfectly well on both snow leopard and lion. There is NO reason that they should not support a less than year old product. My other choice is to buy VMWare ver 4. Their website says it can migrate my existing virtual machine from parallels, but I'm a bit leary of buying it, migration not working correctly and then still having to buy parallels ver 7! I HAVE to have a working VM before the semester starts so I will probably go the parallels upgrade route even though I am NOT happy about giving in to what I consider extortion!

    Sorry to somewhat hijack this thread, but I didn't think a new thread for ver 6 was justified. Just needed to vent a bit.

    tl;dr the above fix only works for Parallels Ver 7, Ver 6 users must upgrade or downgrade back to Lion.
     

Share This Page