Parallels file associations

Discussion in 'Windows, Linux & Others on the Mac' started by tehn00p, Sep 15, 2011.

  1. tehn00p macrumors member

    Joined:
    Jul 21, 2011
    #1
    Hey all,

    I was wondering if there was a way to remove the open with file associations that parallels has made. Half of my files will open the windows vm when I click on them which can become annoying. I tried not sharing the windows applications with my mac but that seems to disable coherence (when you can run windows apps like native mac apps).

    Anyone else find this annoying or have a solution?

    VMWare seems to do what I am describing form what I have tried (unity mode shows app icons in the dock like mac apps but it doesn't associate them with files or fill up spotlight with them), but I find parallels to give me much longer battery life and generally faster.
     
  2. tehn00p thread starter macrumors member

    Joined:
    Jul 21, 2011
  3. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #3
    Go to the setting of your Windows VM and unselect the button that says sth like "use Windows Programs on your Mac" and vice versa. That should do it!
     
  4. dsciel macrumors regular

    Joined:
    Jul 13, 2011
    #4

    1. Find your VM – by default they are located in ~/Documents/Parallels/
    2. Right click on the .pvm file and choose Show Package Contents

    3. Delete the Windows Applications folder, and empty the trash.

    hope this works
     
  5. jason27609 macrumors newbie

    Joined:
    Feb 4, 2012
    #5
    File associations fix

    I had the same problem with parallels 7 automatically associating certain files to windows. One way to fix this is to select the file that is linked to the VM and press command+i (i.e. "get info"). Find the "Open with:" drop down menu and click on it. This gives you the option to choose the application that you want to use, to open that file type. Choose the application that you want to use and click the box that says "Change All...". If you pick a mac application this should fix the problem for that file type.
     

Share This Page