Parallels forcing upgrade for Mavericks

Discussion in 'Windows, Linux & Others on the Mac' started by BiggAW, Oct 24, 2013.

Thread Status:
Not open for further replies.
  1. BiggAW macrumors 68020

    Joined:
    Jun 19, 2010
    Location:
    Connecticut
    #1
    I've gotten several emails from Parallels about how they are dropping Mavericks support from older versions, and you have to upgrade to version 9. Now if it was normal software that provided free updates, I wouldn't care, just download and install, it takes like 5 minutes. However, it really pisses me off after several upgrades in the past.

    I guess the answer is to convert the drives over to simple drives and move to VirtualBox, as this is just ridiculous, and I'm not going to keep paying them over and over again for what amounts to the same product. [/rant]
     
  2. jrs22 macrumors 6502

    Joined:
    Aug 1, 2012
    #2
    What version of parallels do you have now? The emails I'm receiving just talk about how much better v9 is as compared to v8 without actually saying that v8 won't work.
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
Thread Status:
Not open for further replies.

Share This Page