Parallels has deleted my Windows drivers in Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by jamesybsu, Jan 24, 2008.

  1. jamesybsu macrumors regular

    Joined:
    Jun 12, 2007
    #1
    I installed Parallels, and tried running it inside of Mac OSX Leopard, and I was never asked to enter my Windows Activation key. So I hit the green start and it began loading Windows, then all of a sudden it quit, and asked to submit error report. I booted into windows restarting and using the "alt", and Windows XP loaded fine, and it asked me install a driver, and I did. After I used XP for a bit, I went back to OSX, and now when I try to reboot into Windows, it loads completly, but takes much longer than it used to, and when its done loading, I try to use the mouse, keyboard, etc, nothing works. It appears none of my drivers are working, including a USB mouse or keyboard. I tried to uninstall Parallels and I still can't use my mouse, keyboard in Windows. I also tried to run in safe mode, and it still does not recognize my mouse or keyboard. XP worked fine until I installed Parallels, what can I do to make it work again?
     
  2. jamesybsu thread starter macrumors regular

    Joined:
    Jun 12, 2007
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    Insert your leopard dvd when you are booted into windows. Driver installation should auto-launch.
     
  4. JonD25 macrumors 6502

    Joined:
    Feb 9, 2006
    #4
    I had almost the exact same thing happen. Reinstalling drivers wouldn't work. My only solution was reinstalling Windows. I put it off for a while, but decided to go for it recently, and everything works fine again. I just don't use Parallels anymore.
     
  5. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #5
    When my parallels installation messed up, I found the best way to deal with it was to reinstall Parallels and then to get everything working in it.

    Then to uninstall the parallels software it installs in Windows.

    Then to use Parallels to remove data from the partition

    Then to uninstall Parallels.

    That got my "blue screening Vista after parallels removal" partition to run perfectly
     
  6. jamesybsu thread starter macrumors regular

    Joined:
    Jun 12, 2007
    #6

    Ive tried using the leopard disc, but the problem is it won't detect anything, it just locks up everything.

    I will try to reinstall Parallels and get it to work right, then delete it to see if that works.
     

Share This Page