Parallels Networking Assistance Please!

Discussion in 'Windows, Linux & Others on the Mac' started by bugfaceuk, Apr 7, 2006.

  1. bugfaceuk macrumors 6502


    Nov 10, 2005
    Calling all clever people....

    I can't get networking working with parallels... I have an iMac Core Duo (duh) 17'' and connect using airport to my home network.

    I've tried all the en0/en1 combinations (but I'm not sure which one is my airport card, so just tried both) with and without the REALTEK/Parallels drivers... they look fine from the XP side, just don't seem to go anywhere....

    I'm certain I'm missing a step, just I have NO IDEA what that step is!

    Thanks in advance,

  2. groovebiscuit macrumors newbie

    Feb 8, 2006
    I can't really help I'm afraid but I just wanted to mention that I was having the same problem last night with Airport.

    However, if I connected to my home network using an ethernet cable instead it worked fine using IIRC the en0 setting.

    Tried all sorts of things and couldn't get airport going properly.

    I also spent ages trying to figure out how to copy files between the host and guest OS and never found a solution.

    Still, other than that, Parallels is great.
  3. bugfaceuk thread starter macrumors 6502


    Nov 10, 2005
    Very strange, I did have a look at the documentation for the Linux builds and essentially when connecting to a wireless network they suggest a port-forwarding arrangement, but given they were really just saying "type these commands", it wasn't clear what the actual problem that was being solved was.

    Shame, wired isn't a workable solution for me. Grrrr...

    As you say however it's an excellent product otherwise!
  4. rumbletum macrumors regular

    Apr 2, 2005
    Wolverhampton, UK
    I've had the same problems too, and after looking around their forums it appears that wireless isn't supported as yet
  5. jibberia macrumors newbie

    Sep 30, 2003
    I'm having trouble too - I didn't get ethernet or wifi to work. (though I was hurrying with the ethernet part - I'll have to revisit that and see if I can get it to work, as it seems that some of you have got it).

    Can anybody who has it working post some comments on what they did? I'm quite eager to have this working.
  6. bugfaceuk thread starter macrumors 6502


    Nov 10, 2005
    Just tried switching to a wired network... still no joy, I'm clearly doing something fundamental wrong? Is it "just working" foreveryone else?
  7. MRU Suspended


    Aug 23, 2005
    It doesnt work yet period. Same as sound, graphics acceleration and usb support isnt great either. In its current state it's ****.
  8. dougmckee macrumors newbie

    Jan 6, 2003
    wireless works with beta2

    I just installed Parallels beta2 and changed my ethernet bridge to eth2 and checked the [new?] wireless adaptor box and it works like a charm. They've got some seriously smart people at the company.

  9. Senbei macrumors member

    Mar 2, 2006
    Definition of BETA software :rolleyes:

    Additionally, bitching about it isn't going to change anything unless you send feedback directly to them with as much information as possible so they can address such issues.
  10. bugfaceuk thread starter macrumors 6502


    Nov 10, 2005
    And behind the **** are the letters B, E, T, and A.
  11. bugfaceuk thread starter macrumors 6502


    Nov 10, 2005
    Just confirming it works for me too... seems also to "live better" with the rest of my os-x apps too... couldn't say how, it's just happier....

  12. maxim.porges macrumors newbie

    Jun 3, 2006
    Use Host-Only Networking with Internet Connection Sharing


    You should take a look in the Parallels PDF manual, it's pretty good.

    I had the same issue described - in Bridged mode, networking worked great over an Ethernet cable, but failed to work with Airport. My buddy at work and I tried to figure it out, but couldn't. Uninstaling and reinstalling both the Parallels software and the Parallels Tools on the VM failed to fix it.

    I checked the manual, and they recommended on page 100 that you use a special mode called "Host-Only Networking with Internet Connection Sharing". What this does is sets the VM up in Host-Only mode, and then has your Mac share its Internet connection from Airport with the VM from the Sharing tab in System Preferences.

    After following these instruction, I was able to get online, connect to my local network, and also get my Windows-based VPN client for work running in this configuration.

    Good luck getting it working on your machines. I can honestly say this is the only problem I've had with Parallels in RC2 - this is a solid piece of software and I'm thrilled that somebody created a product to fill this needed niche.

    - max
  13. MRU Suspended


    Aug 23, 2005
    |Not had any problems with airport in parallesls for a while now, but I'll try that suggstion to see if I can get ubuntu linux to work properly with airport.
  14. mitcho macrumors newbie

    Jan 3, 2002
    Where is the wireless adapter box?
  15. topramen macrumors newbie

    Jul 24, 2006
    Network bridge fails to assign valid IP address to VM

    I am trying to use the Parallels Desktop for MacOS to install Ubuntu linux
    from the Ubuntu LiveCD distribution.on my MacBook (1.25GB Memory, 2x2.0 GHz Intel Duo Core)
    I have run into several problems, (once I finally got the activation key).

    The first is that bridge networking does not seem to work.

    I checked the FAQ's and newsgroups, and I have tried bridging eth0 to en0 (ethernet) and en1 (airport) to no avail.
    I also tried using host-only networking without success.

    My host IP address was, however, in the VM, I was assigned an IP address of, with a gateway of, and I was unable to access the outside world.

    Is there a way to verify that the bridging succeeded, perhaps by connecting to the virtual machine from the host machine, say via ssh?
    From the newsgroups, it appeared that when bridging works, both the VM and the host get separate IP addresses from the DHCP server, but they share the same MAC address.
    However when I configured eth0 (VM) to bridge to en0 (Host), in this case, the MAC address for the eth0 device attached to the VM is
    00:07:8D:03:17:89 but the MAC address for the en0 device attached to the Host machine is

    I am getting the sense that the VM was never assigned an IP address by the DHCP server, so what I am getting is some kind of default dummy IP and MAC address.

    Any clues for me?
  16. trooperdave macrumors newbie

    Aug 14, 2007
    Paralles user needs help with networking

    I am new to the iMac world an am baffeled. I have a wireless network, but my iMac is connected via Ethernet cable. The wireless router sees the XP VM IP address, my wireless Dell laptop sees MSHome on the VM, but will not access the files. The Dell is able to access the iMac files and the iMac is able to access the Dell files. Paralles is set to the Bridge mode. I've tried a number of things, but figure I'm just missing a step or two. Any help will be greatly appreciated!!
  17. dalinama macrumors newbie

    Oct 19, 2007
    select Network Adapter 1 > en1: Airport/Wireless Adapter (& Restart PC or flush dns)

    I tested it and it works fine for me. Just:
    1) Select "Network Adapter 1" > "en1: Airport/Wireless Adapter"
    2) Do NOT select "Host-only Networking" or "Shared Networking". I repeat, select nothing!
    2) Restart PC (or in CMD console, type "ipconfig -flushdns")
    I am using a MBP 2.4GHz / Parallels 3 Build 5160
    :) I truly hope this helps. :)


Share This Page