Parallels: Networking Problem on Mac Pro

Discussion in 'Windows, Linux & Others on the Mac' started by BadRambo, Sep 8, 2006.

  1. BadRambo macrumors member


    Aug 20, 2006
    Well, heck, after all the excitement about "Mac Pro compatibility" with the new update of Parallels, I loaded TWO guest OSs, XP and Win2K, and niether one of them would connect to anything on the net. All else is healthy on my Pro, both OSX and BootCamp-installed XP working fine. I tried both the Parallels tools network drivers and the standard drivers --- niether one worked. The strange part is that there is activity on the networking ports all the way out of the router here, but there is just no connect, ever.

    It appears that others are having similar issues with networking with Parallels --- any comments, workarounds, etc.?? I have sent a note to Parallels describing the issue --- anyone else have any luck finding a silver bullet??

    Thanks for any feedback -- Bob --- :confused:
  2. grimmwit macrumors newbie

    Jul 14, 2004
    Rio Rancho, NM
    One idea . . .

    I had a weird problem with Windows XP / IE / Parallels RC on my Mac Pro. I could ping anywhere I wanted. But I couldn't successfully connect to my Windows Domain Controller, and I could not surf most web sites. I found this error in my XP event viewer:
    "TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts"

    After googling around, I tried a utility to hack tcpip.sys to raise the number of allowed connections. No luck.

    I found another suggestion to lower the MTU to 576. Tried this and it worked. You add the registry key to this location using Windows Regedit tool (this post assumes that you are comfortable with Regedit and know how to use it)

    My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP\Parameters\Interfaces.

    After this key, you'll see several folders named something like {02475EEEF-xxx... etc)} Look at each of these and locate the one that includes the IP address in use by XP. Add the key to this folder. Exit, reboot and see if that helps.

    Long term, I'll experiment with the MTU size. 576 seems kinda small.

  3. BadRambo thread starter macrumors member


    Aug 20, 2006
    Well, I got an answer back from Parallels, which was less than satisfying. Just pointing me at the workarounds on their site, which are not solutions. As for this specific issue with the networking, their solution was to use fixed IP addresses -- which is not satisfactory for DHCP-driven systems and ISPs. There were no comments about fixing the problem or when.

    Guess it will just sit on the shelf until we see if they fix these major issues. Meanwhile, it is BootCamp XP, which, by the way, is working exceedingly well.

    Cheers -- Bob -- :D

Share This Page