Parallels will not mount my winxp.hdd

Discussion in 'Windows, Linux & Others on the Mac' started by chadwicktd, Sep 28, 2007.

  1. chadwicktd macrumors newbie

    Joined:
    Sep 28, 2007
    #1
    I have had parallels runnung for about 4 months. Today I tryed to start up the virtual machina and it gives me the error: Parallels is unable to access the virtual hard disk image file. The file is corrupted.

    any suggestions as to what I should do?
     
  2. iBecks macrumors 6502

    Joined:
    Nov 24, 2006
    Location:
    Nottingham, UK
    #2
    Use the back up that you created, you did create a backup, didn't you?
     
  3. yhc2k macrumors newbie

    Joined:
    Dec 7, 2007
    #4
    fixing permissions

    I know this is an old thread, but I had this same problem after upgrading to Leopard. I have checked multiple forums and none of the suggestions worked.

    -I upgraded to the newest build (5582 I think).
    -I looked for the .lck file--not there.
    -I changed the name of the .hdd file--no luck.
    -I rebooted my computer several times--no luck.
    -I uninstalled and reinstalled Parallels several times--no luck.

    Here is what solved this issue for me:

    -Go to the winXP.hdd file (or windows.hdd file as the case may be) (under users/<>/library/parallels/Microsoft Windows XP/
    -right click and choose 'show package contents'
    -this should reveal two files: "DiskDescriptor.xml" and "windows.hdd.<lots of letters>.hds"
    -right click on each of these files and select "get info".
    -under each info window, check the "Sharing and Persmission" settings for each file.
    -they should allow your user ID to read/write. I also made it so all of the permissions were the same between the two files.
    -I am not sure if you need to do it for both files, but I did and it fixed my problem! ...so I'm not touching it anymore!

    This cost me a full day of work! Hope it saves someone else some time...
     
  4. Omne666 macrumors 6502a

    Joined:
    Sep 16, 2010
    Location:
    Melbourne, Australia
    #5
    Unbelievable as it may be, but this advice just saved me...6 years later!!!:eek:
     

Share This Page