Parallels, Win7/32bit to Win10/64bit, for free (via Win10/32bit)

Discussion in 'Windows, Linux & Others on the Mac' started by D.T., Jan 14, 2016.

  1. D.T. macrumors 603

    D.T.

    Joined:
    Sep 15, 2011
    Location:
    Vilano Beach, FL
    #1
    Howdy!

    Thought this might be informative or helpful for folks who might want to take advantage of the free Win10 offer from MS. So I've been using a Win7/32bit in Parallels for about 4 years - amazingly enough, it was the original install on an HP notebook from 3 years before that (used the migration tool in Parallels).

    I've been OK with it, as I primarily use that VM for supporting from Federal dev work (it probably comes as no surprise that they're way behind on their tech).

    So anyway, I've been doing some much more modern dev work on MS platforms (FWIW, I also use the native OS X side for a significant portion of dev/design/writing), so I've kind of been wanting to upgrade, I skipped Win8 for the most part (did install a VM, but never activated it, just used for some testing), but like what I saw with Win10.

    I also wanted to migrate to a a 64bit version of windows (you can't do an "in place" upgrade from a 32bit WinOS to a 64bit).

    Here's what I did, note all the Windows versions are the Pro flavor:

    Backed up the Win7/32 VM

    Downloaded the MediaCreationTool (windows app, 32bit version), since the Parallels video driver won't pass the compatibility test if you try to upgrade using the online tool

    Used that to download and install Win10/32bit, everything activated as expected after a couple of reboots

    Downloaded the 64bit MediaCreationTool, and used the download ISO option to score a 64bit Win10

    Installed Win10/64 into a new VM

    OK, this all sounds good so far - but then I ran into a problem with being able to activate Win10/64 - I tried my original Win7/32 key, nope. Tried my new Win10/32 upgraded from Win7 key (it was different), same thing, nope.

    I setup an MS login on both machines (using an existing Live/MS account), nothing, won't activate.

    So this is where I'm not 100% sure what solved the problem, but I applied the last round of updates on my Win10/64, shut it down - then in the Parallels config, I made sure the two VMs were identical, including the MAC address - it was my theory that part of the online activation may have something to do with identifying the same machine "signature".

    At any rate, the cold start after the last updates and matching machine configs resulted in an activated, Win10/64bit VM! Specifically, using the new Digital Entitlement mechanism.

    I swapped my original Win7 back out with the "temp" upgraded Win10/32 machine, though that's mostly irrelevant, as I don't think I plan to use anything moving forward other than the fresh Win10/64 bit machine.
     
  2. pseudoware macrumors member

    pseudoware

    Joined:
    Dec 20, 2015
    Location:
    Nor*Cal
    #2
    Sounds like matching up the VM details did the trick.

    I had my W7 Pro disk w/key lying around. I installed that in Parallels, then did the in-place W10 upgrade. Activated fine, runs like a champ.
     
  3. D.T. thread starter macrumors 603

    D.T.

    Joined:
    Sep 15, 2011
    Location:
    Vilano Beach, FL
    #3
    Yeah, I wish I would've been a little more "scientific" about the Win10/64 activation (i.e., what specifically resolved it), but I guess the takeaway is: it will authenticate from a fresh install, in a new VM with some combination of matching the VM configs, applying all updates and rebooting a few times :D
     

Share This Page