Parental Controls Time Limits not working

Discussion in 'OS X Mountain Lion (10.8)' started by Reckful, Jul 28, 2012.

  1. Reckful macrumors newbie

    Jul 28, 2012
    Mountain Lion parental controls time limits no longer work properly. There are now no warnings that a user's time is up plus it won't log them out automatically. So as long as they don't log out, they can play all day. My children notified me of this glitch ~ they're too honest! Mountain Lion still keeps track of their time. If they've gone over their time limit and they log out, Mountain Lion will not let them log back on. And if, for example, I give them a 15 min extension to log back in but they've gone over by half an hour, they'll get logged out immediately and I have to give them another extension or a longer one. Anyone else having similar issues?
  2. herteltm macrumors newbie

    Jul 29, 2012
    OS 10.8 parental-control time-limits don't work

    Same problem here. Haven't found a remedy yet. In fact my wife has asked me to pleeeease downgrade to 10.7 if I can't fix the problem. Help.
  3. dennismo macrumors newbie

    Aug 9, 2012
    Hi Guys,

    I have exactly the same problem in both my Macbook and the iMac. Fresh installation on both machines. Time limits doesn't work. I cannot figure out what is wrong. Any ideas?

  4. C.G.B. Spender macrumors member

    Jul 10, 2012
  5. lescuderomama macrumors newbie

    Aug 18, 2012
    I am having the same problem. I am now logged into my daughter's account, which has a time limit of 11:00EST (it is now almost 1:00 a.m.)! I even logged out and then logged back in again!

    Why in the world would a company as big and as (supposedly) good as Apple have such an onerous bug in such a simple program!

    It's the little things like this that determine how I feel about a company.
  6. MacConeghey macrumors newbie

    Aug 20, 2012
    Applecare Solution

    I just got off the phone with AppleCare about this very issue. They said that this first release of Mountain Lion is having problems when both the time limit and the bedtime restrictions are activated. When I had both limits set for my kids accounts the bedtime function was the only feature that functioned properly. Once I disabled the bedtime restriction the forced sign out of the time limit became functional this evening. I hope that Apple gets this worked out so the features will BOTH be functional, but at least without switching back to Lion you can use one of them it seems - time limits for my kids!
  7. bkpingel macrumors newbie

    Aug 28, 2012
    Parental Control Time Limits

    We have been having the same problem since we upgraded. We have noticed that once our boys log out they aren't able to log back in. We will try disabling the bedtime feature like the last post and see how that works. It did create some long discussions in our house about honoring limits. It was too bad that it was a programming error.
  8. paul.lambert macrumors newbie

    Sep 2, 2012
    Remote Admin from ML causes same problem on Lion.

    Hi Everyone,

    I came across an interesting twist to this problem. I have an iMac on Lion which I allow remote control for Parental Controls. I have a MacBook Pro on Mountain Lion. I remotely updated the Parental Controls on my iMac (Lion) from my MacBook (ML), and now the iMac is exhibiting the same problems as described in this post ... this problem has propagated to Lion!

    Very disappointed in the lack of testing for this feature. Steve Jobs is probably rolling in his grave. :(
  9. herteltm macrumors newbie

    Jul 29, 2012
    Parental controls regained functionality with OSX 10.8.2 update

    After updating Mountain Lion to 10.8.2 the problems with parental controls discussed here are gone. :)
    Time limits now seem to work again. I am not sure if this already happened with the 10.8.1 update, I only tried after installing 10.8.2.
  10. gigas65 macrumors member


    Mar 17, 2009
    Salonica, Greece
    I have the same problem in 10.6.8 but is the closest discussion related to it

    Please help!!
    After two years of controling my kids' time limits and specific login time restrictions, it seems impossible to do it now.
    Somehow settings have been messed up and having tried many solutions read in forums, i have not managed to fix it. Neither time limits nor time logins work. Even after the 15 minutes warning that the account's time is approaching to end, it keeps logged in for another hour more or less.

    iMac (21.5-inch Late 2009), Mac OS X (10.6.8)
  11. SteveBrooker macrumors newbie

    Oct 19, 2014
    Still not working in OSX 10.9 Mavericks

    For me, upgrading our kids iMac to OSX Mavericks 10.9.4 has proved a disaster for our family harmony. On OSX Mountain Lion we had a well controlled family routine which allowed both kids to have their own time on the computer, not get in each other's way and be logged off after an allotted time which was accepted by us and them We had no arguments related to compuetr access. This has all gone for a burton as the time limit controls are now completely useless.

    The controls (time limits and bedtimes) work sometimes and then they stop. After the original upgrade they did not work at all, then for no apparent reason (unless you call one of a series of unrelated power offs - a reason) they started working and all was well for a week or so, until I wanted to change the time limit for one child and the result of this was that all the parental controls stopped working for all managed accounts.

    I am not alone. I have seen other posts on this topic.

    Please do not tell me, that my kids must have access to the admin password, because they do not. I change it regularly and one of my kids has learning difficulties and would not be able to type it in if he did find it out!

    I have sat and watched. The log in time controls (bedtime limits) work, but once they log in they can stay on as long as they like and the system does nothing about it.

    Please do not tell me, that I should not combine bed time limits and overall time limits. I need both and the system is meant to deliver both.

    I am losing my faith in Apple, despite having an iPhone and iPad, 2xiMacs and a Macbook and having thrown everything concerned with Microsoft (except Office for Mac) in the bin. iMac's are not cheap computer but I bought them because I trusted Apple to deliver what it says on the tin and to do it well. They used to but in this respect I am becoming seriously disillusioned.

    Should I upgrade to OSX Yosemite! Will this cure the problem. I doubt it. Is there a later version of Mavericks. I will try anything to get back peace to the house.
  12. npilch macrumors newbie

    Oct 19, 2014
    Yosemite parental time controls flakey but better than Mavericks so far

    My son updated his computer to Yosemite and parental controls are working flakily. However, they do seem to enforce time limits better (too aggressively sometimes) whereas as this would stop working in Mavericks it seemed.
  13. jeremybassett macrumors newbie

    Dec 4, 2009
    Complete Dogs Dinner

    I am in the same boat. These controls, as well as being inadequate (like not being able to differentiate between a Friday and Saturday), have caused all kinds of grief. I spend most of my time extending the time limit because it does not keep track of the time spent only to be reset again. I might see if I can turn off the time-of-day constraint to test just the time limits, but before I know it they'll be up at 05:30 again playing bloody Minecraft...

    I will also file a bug with Apple.....
  14. SteveBrooker macrumors newbie

    Oct 19, 2014

    For no apparent reason (I have changed nothing) the parental controls on my iMac with Mavericks have started working again (at least on one managed account - for me the most important child to be managed). I almost dare not touch anything related to the parental controls again, unless they stop working again. Why does Apple not try and fix bugs? Perhaps they think restricting access to computers is against their long term interests!
  15. tillsbury macrumors 65816

    Dec 24, 2007
    They are very much broken in Yosemite. My son's computer logs off, and when he tries to log in again it asks for a password for more time. I enter an additional hour, it logs in and immediately logs off. This can happen two or three times. Just now, I did it for the third time and it logged in successfully, and gave him 13 hours 12 minutes.

    Sometimes it takes on the second go, and gives an hour correctly (but I've had to enter it twice). Sometimes it simply won't log on at all and power off/on is the only solution.

    I wish they could finally get this working.

Share This Page

14 July 28, 2012