Parted Magic Linux boot CD

Discussion in 'Mac mini' started by Chippy99, May 28, 2012.

  1. Chippy99 macrumors 6502a

    Joined:
    Apr 28, 2012
    #1
    I might be doing something wrong, but I have been trying to boot a linux CD on my Mac Mini, but no matter what I try, I cannot get it to boot.

    I am wanting to do a secure-erase on my SSD, which requires booting Linux to run the Parted Magic utility. I downloaded a disk image from the Parted Magic website and burned it to a CD. The CD boots perfectly if plugged into my Windows PC. But plugged into the Mini, I just get a black screen and nothing.

    Has anyone managed to boot a Linux CD on their Mini?
     
  2. McGilli macrumors 6502

    Joined:
    Nov 11, 2008
    #2
    You can use the secure erase feature in the OSX Disk Utility.

    It can secure erase to US Department of Defence (DOD) 5220-22 standard.

    Just boot into OSX recovery on a USB flash drive or dvd...
     
  3. Chippy99 thread starter macrumors 6502a

    Joined:
    Apr 28, 2012
    #3
    I suspect that's not the same thing.

    I am talking about sending the ATA erase command to the SSD controller, which then zaps all the memory cells.

    Writing zeros or other data (as per the OSX utility) is not what you want to do. And incidentally, it doesn't guarantee destruction of all the data because of the way the SSD controller abstracts away the physical memory cells from the external view presented to the sata controller and OSX. Plus SSDs have extra capacity that you can't see, but which will contain data.
     
  4. silverjam, Jul 1, 2012
    Last edited: Jul 1, 2012

    silverjam macrumors regular

    Joined:
    Apr 25, 2012
    #4
  5. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #5
    Which Mini? There are known issues with booting Linux on mid-2011 Minis.
     
  6. Chippy99 thread starter macrumors 6502a

    Joined:
    Apr 28, 2012
    #6
    Latest model. I have tried all sorts of things to boot a linux installer of some kind (CD or USB) and nothing has worked.
     
  7. silverjam macrumors regular

    Joined:
    Apr 25, 2012
    #7
    I have a Mac Mini Server and MM i5 both current models and can boot into Parted Magic and do Secure Erase on an SSD. I can also boot into my MBA 2011. I have posted some links to my procedure that you might like to check. I suspect possibly either your boot disk is not bootable (see my procedure using OSX Disk Utility to make a boot disk). Also is your drive encrypted? If so the Option boot option won't work.

    Also if you are using the current blue tooth keyboard they can be tricky to boot with. My suggestion is click space before you press power on the MM to make sure the key board is active, then click the boot keys (Option etc) about a split second before the chime.

    Check my other posts out. I go into reasonable detail on booting and using Parted Magic to Secure Erase a MBA SSD.

    I don't have all the answers but my system worked for me on a number of Macs.

    Silver

    ...................

    Earlier Post....

    This process worked of me on my Mac Mini with no freezing but I have an OCZ SSD.

    http://forums.macrumors.com/showthread.php?t=1395431

    Silver

    ----------

    Also you might be interested in this post of mine.

    http://forums.macrumors.com/showthre...cure+erase+ssd
     
  8. Chippy99 thread starter macrumors 6502a

    Joined:
    Apr 28, 2012
    #8
    Thanks for the info. I will have a go with your procedure, but I can't for the life of me understand why it works for you and not for me. I have basically done the same things already.

    Yes, bluetooth keyboards can be tricky! I have a wired keyboard just for this.

    I'll let you know how I get on. I am not too bothered about what SSD you have. I am more interested in just being able to boot a linux image of some type, and then I can run my own SSD firmware utilities. Up until now I have failed at first hurdle by not managing to boot anything other than OSX or windows under bootcamp.
     
  9. silverjam macrumors regular

    Joined:
    Apr 25, 2012
    #9
    I have heard that Mac won't boot anything unless it is Mac based. I understand this to be:

    OSX, Time Machine, SuperDrives and External Drives with Mac OSX on them etc (General List). I say that because I believe they will not boot USB thumb drives and will not boot non-apple CD drives. But my external USB SuperDrive is OK because it is a Mac device.

    I note this just for possible elimination of problems at your end, and yes there are possibly still a million other boot options that work or that I am wrong about. Simply put, make sure you boot from Mac stuff to try and eliminate any problems.

    This was mentioned as an issue on the OCZ SSD Boot Procedure on the link I provided. Weather it is try or not I don't know.

    Silver.
     
  10. Chippy99 thread starter macrumors 6502a

    Joined:
    Apr 28, 2012
    #10
    Well you raise an interesting point in that my cd drive is not Apple. It would seem odd if this is this problem, but maybe.
     
  11. silverjam macrumors regular

    Joined:
    Apr 25, 2012
    #11
    OCZ Forum on Booting to Linux CD said this:


    "It is recommended that MAC users burn this [OCZ Linux Utility] to a CD. To my knowledge you cannot boot from a USB stick or even a USB CD drive unless you are booting an OSX install media.
    An example for burning the ISO on a Mac can be seen here: http://lifehacker.com/251758/mac-tip...g-file-to-disc"

    This comes from:

    http://www.ocztechnologyforum.com/f...-for-OCZ-SSD-s&p=714047&viewfull=1#post714047
     

Share This Page