Partition Failed

Discussion in 'Mac Pro' started by casw1000, Feb 19, 2008.

  1. casw1000 macrumors member

    May 6, 2005
    Hello all. I have my nice shiny new MP2.8 now for 1 week. So I decided it was time to start from scratch with new hard disk layout and rebuild the system.

    Bay 1 - 750 Samsung F1
    Bay 2 - 320 Original WD Apple supplied HDD
    Bay 3 - WD Raptor 74GB 10K
    Bay 4 - WD Raptor 74GB 10K

    I deleted the original install on the 320gb. I created a stripped array for the two raptors. I highlighted the 750GB Samsung, click on partition and click the plus sign to create a single partition, click apply + partition =

    "Partition Failed"
    Partition failed with the error : Cannot allocate Memory

    Has anyone else seen this problem before. I can partition the other drives no problem. No I dont have another system to test this in.

    Any thoughts or experiences would be welcome. Google and MR Search is not giving much help.

  2. casw1000 thread starter macrumors member

    May 6, 2005
    I couldn't let this beat me otherwise I would not sleep. So I went round a friends house and get them to boot off a linux liveCD and fired up GParted. Nothing, it seems that although the BIOS can see the hard disk, nothing else can.

    Given this is the first time the drive has been powered up, I am going to get this swapped out tomorrow and then test the replacement at work. I will update accordingly.

  3. Consultant macrumors G5


    Jun 27, 2007
    Macs don't have BIOS.

    Under disk utility / Partition

    you might have to go under "Option" to choose
    GUID Partition Table
  4. Banacek macrumors 6502

    Jan 13, 2008
    Just a heads up, I had a few of these errors right before my Mac Pro died. Also with the same exact drive.
  5. casw1000 thread starter macrumors member

    May 6, 2005

    Thanks. I did have a go at setting the GUID under the option, but that didn't really do anything. When I connect the drive on a pc, the bios does correctly see the drive type. Linux also sees the drive but constantly scans during the Gparted search.

    However After moaning at the local supplier about this drive, they said I had "initalized" the drive, when I explain I don't have a windows machine, therefore I could not do this. They said, the drive is not faulty, I had to initalized the drive then it would work.

    So I took the drive into the office and ripped open a vista machine, installed the drive as a second drive and Vista saw the drive as foreign. I could then initalize the disk and I could format.

    So I shutdown the computer, booted from a LiveCD Ubuntu and tried to install, hey presto, the drive can now be seen within linux. I will install the drive in the Mac later as I am sure it will now work.

    However, this is the first time I have ever needed to do this, just to get the drive to be seen by any operating system.

    Thanks guys for your help. Weird one eh?
  6. Ol!ver macrumors 6502a

    Mar 2, 2005
    Did you ge tthis sorted? I'm having the same error installing a new HDD in a MacBook.
  7. Evil-Shadow macrumors newbie

    Dec 12, 2008
    New MacBook HDD

    yea ive had the same problem when i try to partition my new WD 320Gb HD it says it Cannot Allocate Memory ive installed windows on it perfectly and it works fine but the MacBook jus doesnt want to acknowledge the HD exists!
    if i take the HD out n put it back in while preparing to install Mac OSX it then appears in Disk Utility but when i try to partition it it jus says Cannot Allocate Memory i have no idea why this is.
  8. lostngone macrumors 65816


    Aug 11, 2003
    I know you said its new but what version of install media are you using? Is it 10.5.0 or is more current like 10.5.4.

    I would say try a different version of the install media.
  9. Evil-Shadow macrumors newbie

    Dec 12, 2008
    WD3200BEVT 320Gb HD

    i cant be too sure but my Mac OSX dvd says Mac OS Version 10.5 how would i go about getting a different version of the OS?
    the only problem is that it doesn't recognize the HD when i go to install Mac but while the install screen is up with Disk Utility if i remove the HD and re-insert it it comes up but when i try to partition it it says Cannot Allocate Memory
    ive see posts on here of people with the same HD as me saying it installed perfectly
    help is much appreciated thanks!
  10. Semiopaque macrumors regular

    Oct 7, 2008
    Just to clarify something you said, you put Windows on the drive and it is still currently on the drive when you try to install OS X? Is it possible you have it setup with MBR partition table?
  11. Evil-Shadow macrumors newbie

    Dec 12, 2008
    I think ive fixed the problem now. for some reason it wouldn't allow me to erase or partition the HD in the install setup, so i used my 8Gb mem stick duo through my PSP to install Mac OS X on it and the once Mac is running it would allow me erase the HD in Disk Utility although because of the size and speed of the 8Gb mem stick it took a bloody long time haha.
    dunno why it wouldn't let me partition the drive in the install menu though rather odd.

Share This Page