Partition on external drive won't mount

Discussion in 'MacBook' started by Low J., Aug 17, 2009.

  1. Low J. macrumors newbie

    Joined:
    Apr 12, 2008
    Location:
    Raleigh, NC
    #1
    I've got an external 500gb Seagate drive with 2 journalised partitions.....one for my time machine backups and the other for holding audio samples for my drum machines and such. All of a sudden today the audio partition won't mount but the time machine partition still works fine. I go into disk utility and it shows ther but just says unable to mount when I try to mount it. It suggests first aid so I verify and repair numerous times and it says everything is ok. I can boot up Ubuntu in VMware andboth partitions are visible and all the files are there....everything is just as it should be. I was using 10.5.7 and just upgraded to 10.5.8 tonight and nothing changed. I can't find any help that worked in my googling research. Please help!!!! BTW this drive and these partitions have worked for over a year with no issues.....I made no changes to prompt this.....wasn't using the audio files on the drive or anything.
     
  2. core2duo macrumors member

    Joined:
    Apr 26, 2009
    #2
    Do they mount on another Mac? If so, you might have a bad preference file screwing up the works. If not, you could try resizing the partitions if Disk Utility will let you, otherwise you might try something like Drive Genius 2.
     
  3. Low J. thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    Location:
    Raleigh, NC
    #3
    I got my new 15" Macbook Pro over the weekend and it won't mount on that one either. Just like my other one though I can go into disk utility and it shows this partition but does not allow it to be mounted and does not report any issues when I use the verify and repair utilities. I can still mount it and see all the files with no problems though in Linux. Any other suggestions on what might be wrong and why only Mac's can't mount this partition???
     
  4. c12281 macrumors newbie

    Joined:
    Sep 7, 2009
    #4
    Same Problem with Time Machine Not Mounting

    I am having the exact same problem. I am using a 500gb Seagate Drive. I have set up two partitions; one with Time Machine, the other for storing movie and photos files. All has been working beautifully for about 3 weeks. All of a sudden I cannot see the Time Machine partition in Finder. I can see it in Disk Utility -- I verified and ran the repair disk utility and all is "ok", but I am unable to mount Time Machine. I am new to the MAC world and not quite sure what else I should do. Since the Sea Gate is connected through USB there is a chance it was disconnected while running. My son habitually takes my mac and runs without disconnecting the disk from the finder. Could this have caused the problem? If yes, how can I fix it? Thanks for any help you can provide.
     
  5. treyusa macrumors newbie

    Joined:
    Jan 5, 2010
    #5
    Same issue with Seagate FreeAgent 500GB

    Hi there, I am using a Seagate Free Agent 500 GB as my Time Machine disk, and I am running into the same problem! I verified and repaired my TM partition in Disk Utility successfully, but still cannot mount the partition. Anyone have any suggestions? This is particularly insidious behavior since you are effectively losing all your back-ups for many, many months!!

    Any help would much appreciated....

    Other info: Macbook Pro C2D, 10.6.2, external drive connected via firewire 800. Also tried, however, connecting via USB - same problems. CAN successfully connect through Windows via bootcamp (and MacDrive) to read...

    Partition is HFS+ Mac OS Extended (journaled)).

    This is what I see after I verify and repair:

    Verify and Repair volume “TM_200908119”
    Checking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking multi-linked directories.
    Checking volume bitmap.
    Checking volume information.
    The volume TM_200908119 appears to be OK.
    Volume repair complete.Updating boot support partitions for the volume as required.
     

Share This Page