Partition table format error?

Discussion in 'Mac Basics and Help' started by snakester, Aug 31, 2009.

  1. snakester macrumors newbie

    Joined:
    Aug 30, 2009
    #1
    Hi,

    My computer's a Mac Mini Core 2 Duo 1.83GHz upgraded to 500GB HD and 4GB RAM.

    I think at one point (probably when I switched from my 80GB to my 500GB drive) I screwed up and made the partition format on my drive Apple Partition Format. As I was just doing disk cloning, Leopard had no problem with this, and never mentioned anything being wrong (if it did I could have fixed it back then). However now, when I try to upgrade to Snow Leopard, it complains about this, telling me I can't upgrade and my only real option is to back up my data and fresh install. Problem being, I don't have a 500GB drive laying around, and I don't have the money to buy a 500GB drive to use once to back up all my data. It pisses me off to no end that Leopard didn't complain about this when I first did it if it was going to be a problem in the future (back when I could have fixed it) and only now it's become a problem.

    I guess my question is, is there any way I can get by this problem and install Snow Leopard? Or am I gonna have to wait till my friend needs to wipe his PC again and borrow his HD for a night?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Do you mean Apple Partition Map? If so (see attachment) your only choice as far as I know is to back up your data and reformat to GUID.

    On the other hand, if you're referring to the Mac OS Extended volume format (see other attachment), that is exactly what you should be using.
     

    Attached Files:

  3. snakester thread starter macrumors newbie

    Joined:
    Aug 30, 2009
    #3
    Yep, apple partition map :(. Now I'm sure it was when I went ahead and swapped the 80GB with the 500GB. Thankfully I have a friend that owes me a huge favor and he's gonna be wiping his PC in a month to put Win7 on it, and I've got an external hot swap bay:D. I'm still not the happiest that leopard's Disk Utility didn't come up with a "WTF are you doing!?!?!?!?" prompt, but, hey you can't have everything.

    Thanks.
     

Share This Page