Partition won't mount

Discussion in 'Mac OS X Lion (10.7)' started by abta1, Jan 11, 2012.

  1. abta1 macrumors 6502

    Joined:
    Jul 5, 2010
    Location:
    Paris, France
    #1
    I have a 2TB Segate drive that is partitioned into two, both HFS. The larger partition has recently stopped showing up and now won't mount. When I go to Disk Utility in OSX and try to mount it manually it tells me to run First Aid. When I do try to verify the disk I see the error "Invalid content in journal" and eventually "The volume Samsung 1 was found corrupt and needs to be repaired."

    However, when I do a repair nothing comes of it and it will still not mount.

    Any ideas?
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    I believe that some of the most recent releases of the "data recovery apps" such as:
    - DataRescue3
    - Disk Drill
    - Stellar Phoenix Data Recovery
    - Nice To Recover
    ....can restore damaged partition maps. Not sure about this, as I've never tried to do that myself.

    Your first efforts should be to repair the partition and/or directory portions of the drive, assuming that the data itself remains intact and undisturbed.

    If that doesn't work, and...
    There seems to be no way to get the partition to mount, and...
    You absolutely have to get that data back...

    ....there is another, last-ditch way to go. You must proceed at your own risk, but it worked for me when nothing else would.

    First - you will need another external drive to serve as a "scratch 'n' recovery" drive.

    Second - back up all the data on the partitions of the problem drive that remain "mountable".

    Third - re-initalize the problem drive, creating a single partition (yes, RE-initialize).
    IMPORTANT IMPORTANT IMPORTANT
    Do not, repeat DO NOT choose to "zero out" the drive as you initialize it. Zero'ing a drive WIPES OUT the actual data on the drive's platters, and there will be nothing left to recover.
    All you want to do is a "quick re-initialization" which wipes clean the drive's _directory_ but leaves the actual data on the drive untouched.
    The goal here is to get the entire drive "mountable on the desktop" again. Yes, it will appear "empty" (new, empty directory) -- but the old data is still there!

    Fourth - use one of the data recovery apps above to search and scavenge the newly-initialized drive, and recover the files to the scratch 'n' recovery disk.

    This takes a little money, effort, and time. But that's how I got my data back when it looked like it was "gone for good", without resorting to a "data recovery service"....
     

Share This Page