Partitioning external Hard drive

Discussion in 'Mac Accessories' started by brightwinds, Aug 21, 2006.

  1. brightwinds macrumors newbie

    Aug 21, 2006
    I've just switched to a Mac, and am trying to convert my old external hard drive into one that's formated for Mac. I erased all the data on it, and have tried to make a partition on it, as right now there are no partitions at all on it, (it says partition scheme: unformatted) but when I try to do so, I've been getting an "input/output error" and I don't know why. Ideally I'd like to have a windows partiton and a mac partition, but again, when I tried to set that up I got an error message. Now, when I try to do anything in disk utility to the HD, it freezes. Any ideas on what to do? At the least, I'd like my hard drive to have some formatting on it of some kind so that I can use it!

  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Generally speaking, in Disk Utility, you'll see the disk twice: The "hardware" of the drive will be listed on the left, and then any partitions/volumes on it will be indented, listed below that. Have you tried clicking on the top item (the hardware one--probably has some garbage-looking name), then going to the "Erase" tab, and "Erasing" it from there? That should completely reformat the drive and create a single partition on it.

    If that works, then at least you've got a useable drive, and you can go back and try the same thing but this time from the Partition tab to try and get the two partitions you're wanting.

    Question: You said "old external", but what, specifically, are we talking about? Interface (USB2/FireWire) and brand?
  3. brightwinds thread starter macrumors newbie

    Aug 21, 2006
    I started it all by doing what you suggested, going to the upper-level of the HD and using the erase tab. When I say "old external" I mean the USB drive that I had used on my PC before, and it says it can be formatted for OS X. I tried to re-erase the hard drive as well, but no matter what I do to it in disk utility it beachballs on me and I have to force quit.

    Thanks for your help so far!

Share This Page