Partitioning problem. (MediaKit reports no such partition.)

Discussion in 'macOS' started by The General, Apr 25, 2008.

  1. The General macrumors 601

    Joined:
    Jul 7, 2006
    #1
    :confused: No idea what this means. I try, over and over to use Bootcamp to install Windows, or Linux, to no avail. When I try to install Windows, I use Bootcamp to partition, then it says "insert your Windows disc" so I do so, then when my computer restarts it spits my disc out and stays at the gray screen for a really long time. I haven't waited to see what happens, I restart. Then if I put the CD in and hold C it tries to boot to the CD, sometimes it will and sometimes it won't. It usually just goes to a black screen with a blinking cursor line thing on the top left of the screen, then after a while that goes away. One time I was able to get Windows to install, after which it would not boot. It says that there's no bootable device and I need to install a bootable device.

    So I gave up on Windows. Next is Ubuntu 8. I tried installing this. I reset my partition scheme using Bootcamp and then I used Disk Utility to resize my Macintosh HD partition to leave room for Ubuntu. At this point it is just my Mac partition and free space. Then I put the Ubuntu disc in and held C, which make it not work. Nothing happened, it spits the disc out, but one time I was able to get it too boot and install, but after that Linux wouldn't boot when I select it after holding Option to get the boot options.

    I researched this and figured that maybe installing rEFIt would help. I installed that, and when I select Boot Linux from HD it shows my a tux logo on a gray background, and some times it shows me a black screen with a blinking cursor, and sometimes it says there's no bootable device.

    Now I can't even get this computer to boot to any CD but the Mac OS X disc. the Ubuntu disc shows me the boot options menu, and when I select "Try Ubuntu with no changes to my computer" it sits there making weird noises from the CD drive and then after like ten minutes it gives up and just shows the menu thing forever.

    Knoppix won't boot, Ubuntu won't boot, I can't get Disk Utility to fix my partition map, and I can't use Linux to fix it. I am very frustrated with myself and wish I'd never started this nonsense last night. I just want to fix my partition scheme but this is what Disk Utility shows me:

    Okay, so I select my Macintosh HD and drag it to be larger, and this is what happens:
    [​IMG]

    MediaKit reports no such partition? WTF does that mean?

    Then I'm like "whatever" and I try to delete my Linux swap partition (this is after I deleted my Ubuntu / partition successfully for whatever reason) and so I select it and hit erase but it just comes right back after saying partitioning complete!

    I'm pretty flustered, I'm going to try booting Knoppix again to see what happens... :mad:

    And all I can find out about this error message is in German:
    http://www.google.com/search?q="MediaKit+reports+no+such+partition"

    :(
     
  2. The General thread starter macrumors 601

    Joined:
    Jul 7, 2006
    #2
    Update:

    I was able to get the Gparted LiveCD to boot, and I was able to remove the "Linux Swap" partition, which turned out to actually be HFS+ for some reason. Now I'm trying to resize my Macintosh HD partition to fill my drive.

    Update 2: It appears to have worked, but that still doesn't solve my CD booting problems and it most certainly doesn't solve the mystery as to what "MediaKit reports no such partition" means...
     

Share This Page