Passcode Lock time w/ 3.1?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by daihard, Sep 9, 2009.

  1. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #1
    Okay, this is very weird.

    Both my wife and I have iPhone 3GS's. We've both just updated to OS 3.1. Now, my 3GS only shows the following choices for the "Require Passcode" option.

    • Immediately
    • After 1 minute
    • After 5 minutes
    • After 15 minutes

    However, my wife's shows two more choices.

    • Immediately
    • After 1 minute
    • After 5 minutes
    • After 15 minutes
    • After 1 hour
    • After 4 hours

    Anyone have any idea what's going on here? I had mine set to 1 hour, but it's forced to be 15 minutes now, and I totally hate it!
     
  2. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #2
    Looks like I've found the cause of the "problem."

    http://support.apple.com/kb/HT3860

    I've just turned off the passcode lock itself. I am not going to let Microsoft dictate how soon I need to type in my passcode to unlock my device!
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    I saw in one thread where people were complaining that the time was now limited to 15 minutes, so I'm not sure how your wife still has 4 hours.
     
  4. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7C144 Safari/528.16)

    My post above will explain it. My wife does not have her iPhone connected to an Exchange server.
     
  5. mikey28 macrumors 6502

    Joined:
    Aug 6, 2008
  6. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #6
    Glad you realized that I was not "confusing the two." :)
     
  7. jonthegeologist macrumors member

    Joined:
    Feb 8, 2008
    #7
    How did you turn the passcode lock off without losing access to your exchange server mail?
     
  8. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #8
    I didn't do anything special. I turned off passcode locking just like I usually do. I am still able to access my Exchange account now.
     
  9. capt601 macrumors member

    Joined:
    Jun 27, 2008
    #9
    I am not convinced on the exchange connection. a coworker and I both updated last night, both with exchange, and his stayed at 1 hour for the passcode lock, and mine reduced to 15 min. discussed with out IT folks and they had no changes on their end.
     
  10. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #10
    See the KB article I quoted in #2. It _is_ related to the Exchange server settings. The Exchange Server side does not have to change anything. It is only that OS 3.1, unlike the previous versions, honours the Exchange setting on the maximum timeout period.

    I'd call your friend's case anomaly. :)
     
  11. maxibenson macrumors newbie

    Joined:
    Oct 7, 2009
    #11
    i think i fixed it

    I had a more severe problem - I only had 1 minute passcode and autolock after upgrading to snowlep and 3.1. Apparently its a Exchange server issue with the new software on the phone and Mac.

    Here was my solution: i turned on "Fetch" in addition to "Push" for e mail retrieval. To save battery i have fetch at 1 hour. What that seems to do is disable the weird time/security restrictions and adds back all the options for longer times.

    I didn't nee fetch at all before but this is a simple workaround, it seems the phone gives you all the passcode and autolock options back when fetch is enabled, and you can still keep push on.
     
  12. daihard thread starter macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #12
    Where exactly did you have "Fetch" enabled? I tried everywhere I could think of, but it had no effect.

    I ended up asking the IT guy to change the maximum time setting on our Exchange server. The max is 1 hour (unless you go to "Unlimited") so he set it to 1 hour. I removed and re-added my Exchange account on my iPhone. I can now choose "1 hour." Good enough for me. :)
     

Share This Page