Passthrough Option Not Available in Export

Discussion in 'Apple TV and Home Theater' started by Bonesone4, Apr 19, 2009.

  1. Bonesone4 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Rochester, NY
    #1
    I'm trying to change an MKV file to an MP4 to stream to my AppleTV and I'm noticing that when I go to export, I am unable to choose "Passthrough" as an option. It's grey'd out. I did a test the other day with another file, same way, and it worked fine. What gives?

    Bones
     
  2. TheNightPhoenix macrumors 6502

    Joined:
    Dec 16, 2005
    #2
    Have you made sure it's on MP4 and not MP4 (ISMA)?
    Also does it have subtitles or multiple sound tracks?
     
  3. hotrod54chevy macrumors newbie

    Joined:
    Jan 26, 2009
    #3
    if you're trying to convert an MKV file with quicktime pro with passthrough (i've never had luck with my :apple:tv seeing the file) you have to make sure you wait until the entire video has loaded (the grey bar at the bottom of the video) and make sure you have the right mp4 selected
     
  4. Bonesone4 thread starter macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Rochester, NY
    #4
    I have done that...made sure the file completely loads, and then choose the correct MP4. I did notice that one flick I tried converting had subtitles in there.

    I also have had a hell of a time getting my appletv to see these files too. It's weird...some work and some dont.
     
  5. smi99th macrumors newbie

    Joined:
    May 15, 2009
    #5
    I am doing exactly the same process to make movie files compatible with xbox 360.

    It's the subtitles that cause the problem. You'll need to remove them in order to choose the pass through option.

    Load the movie in QuickTime, bring up the Movie Properies window (cmd+J). You should see a second video track on the list which is described as a "Text Subtitle". Un-check the box then try to export - things should be ok from there!


    Hope this works and helps you out - it frustrated me for ages....!

    EDIT: actually you'll need to delete the subtitle, not just un-check the box....
     
  6. raseri macrumors newbie

    Joined:
    Feb 16, 2008
    #6
    Muchos Gracias

    Thanks smi99th, I thought I was going crazy. I had two .mkv files open side by side with the info box open trying to figure out what was different. Trying it out now.

    Thank again.
     

Share This Page