Password auto input at login

Discussion in 'Mac Basics and Help' started by galasyam, Aug 26, 2013.

  1. galasyam macrumors newbie

    Joined:
    Aug 26, 2013
    #1
    I just got a new MacBookPro ( something like 2 months now ) and I have already tried to implement the basic protections ( activating the firewall, installing avast, using a password at login ).
    Few days ago, I had to travel and I was connected to a friend`s internet connection( at her apartment, straight from wifi router connected to her modem). For the two first days, things were smooth but the third day, before I went out for lunch, I switched off my Mac and when I came back and started it ... I was given the option to choose between two disks asking me from which one do I want to boot. I selected to boot from MacBookPro ( the other one was named Backup ).
    After complete loading, I was no more asked to enter my password and my session was presented to me. But normally, I should not get to the session without entering my password.
    I was still a bit confused, then I restarted the computer, and indeed it was no more asking for password.
    I am not sure whether someone touched my Mac though...I don`t find any reason why my fiend would have done that anyway.
    Later, I was trying to find whether something else has changed..., then I changed my password and activated identification at login. while I was explaining what happened to my friend, I restarted the computer and to my surprise, the field for the password fills up automatically, it is like someone is typing.

    I am confused and I don`t know what to do... anyone has an idea of what happened and what should be done, please let me know.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    First and foremost, you do not need avast or any form of real time virus software if you are running OSX. There are no known viruses in the wild that can infect OSX.

    If you do want an AV app, then remove Avast and download ClamAV from the MAS...It won't sit in memory and will not cause issues. As far as the password issue goes, it sounds like you've saved it in your Keychain, which is why it's auto filled on startup.

    If you are in any doubt about anti virus software, just search these boards....It's really not required at all.

    Clam AV:
     

    Attached Files:

    • CLam.png
      CLam.png
      File size:
      494.3 KB
      Views:
      59
  3. galasyam thread starter macrumors newbie

    Joined:
    Aug 26, 2013
    #3
    Thank you for your prompt response, I proceed as you recommended about Avast.
    For the password, I`m still reading about KeyChain but do you have an idea of why my password was not asked at login at first ? Is it because the OS was updated or something... ?
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Take a look at your security settings...There is an option to "Require Password At Logon" this can be disabled, or configured as you wish.

    If the setting for apps is "Allow From Mac Store And Developers" ( recommended ) you will be prompted if you try to install third party apps. You'd need to temporarily change it to allow some apps through, but be careful you know what you're installing.

    I'm guessing you probably ticked the "Don't Prompt" box...hence the auotfill.
     
  5. galasyam thread starter macrumors newbie

    Joined:
    Aug 26, 2013
    #5
    Since I first run this Mac, I have set a login password for each user.
    The thing is...I switched of the computer, went for lunch and when I next started the computer, I was not asked to enter my password anymore.
    But is that... I don`t know...Has it ever happened to any of you ?​
     

    Attached Files:

  6. Elbert C macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #6
    In System Preferences > Users & Groups > Login Options, is any of the accounts' Automatic login option enabled?
     

Share This Page