password autofill requires password

Discussion in 'macOS' started by smackawack, Apr 21, 2019.

  1. smackawack macrumors newbie

    Apr 21, 2019
    10.14.4 appears to have implemented an annoying hurdle in safari password autofill. Each time we select to autofill a password or cc I have to put in my user password (or use touchid). This is painfully inconvenient as I'm using this 20x an hour. Do any of you brilliant genius masterminds know how to turn this off? It was so beautiful before.

    I understand it's more secure now...but I severely limit any access to my there is very little risk to me. I want to go back in was. perfect.

    Any help would be appreciated. You guys are the best!!
  2. iTarbuck macrumors member


    Jan 29, 2019
    Liverpool, UK.
    I wouldn't even know how to start, however I would recommend switching to the last-pass password manager, which can be selected as the default autofill service for all iOS and OSX devices.

    Try it - im loving it!!
  3. uniquexoxo macrumors member


    Aug 27, 2018
    South East Asia
    Hmmm I don’t have this issue though. I’m using MBA 2017
    Last pass is great but you need a premium subscription to gain access on multiple devices
  4. BigMcGuire Contributor


    Jan 10, 2012
    Yes, you can turn this off. Go to Settings --> Touch ID --> uncheck Safari Autofill.

    First thing I did. Couldn't stand it as it was so annoying - like you I use this 20+ times an hour. lol. Apologies to @smackawack since no one told you about this before. :/

    It is my opinion that putting this setting here is extremely un-intuitive.
  5. NoBoMac macrumors 68020

    Jul 1, 2014
    And check: Keychain Access > Edit > Change Settings for Keychain Login

    Make sure "Lock after X minutes" is turned off or has a long timeout value.

Share This Page

4 April 21, 2019