Password not accepted on iCloud.com

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Turk February, Aug 1, 2012.

  1. Turk February macrumors newbie

    Joined:
    Aug 1, 2012
    #1
    Looks like others have had a problem similar to this, but not quite the same.

    A few weeks ago, my password was suddenly not working for the Mail app and iCloud.com. (It still worked on my iPhone.) So I reset the password, which helped me get service back on the Mail app, but it still wouldn't work for any iCloud services on the web.

    That's the way it's stood for a while, and today I finally tried to fix it by resetting my password again. Same result, iCloud.com still won't accept it, or any of my previous passwords. So I tried to log on to the Apple Support community for answers. There my new password WAS accepted, but it took me to a screen where I had to pick a username for the forums, and no matter what I picked, it said "An account utilizing this email address already exists." So I was effectively blocked from there too.

    I was a MobileMe member, but switched over at the beginning of the year and didn't have any problems until a few weeks ago, so I suspect the change-over had something to do with it. Any idea what's going on or how I can fix it?
     
  2. Turk February thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #2
    I think I figured it out. Seems I had to specify that I was entering a password for "my-username"@mac.com, rather than @me.com or just the username itself. Just in case anyone else has a similar problem.
     

Share This Page