password prompt disable on startup

Discussion in 'macOS' started by stuartrozier, Dec 29, 2014.

  1. stuartrozier macrumors regular

    Joined:
    Nov 12, 2011
    #1
    Hello,

    Ive been wanting to use a password on my mac, for when i leave the room, screensaver comes on which is good and it requires a password to access the desktop again, which is good.

    but i want to disable the password for when i first turn the mac on, i want it to load straight into the desktop without requiring a password, is this possible ?

    Many thanks,

    Stuart
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    Go to "System Preferences" > "Accounts" > Select your account, Change password, Enter the old password, Leave the new password space blank.
     
  3. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #3
    thanks for this.

    will it still allow me to have a password for the screensaver though ?
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    System Preferences / Security and Privacy / General.

    Uncheck "Disable automatic login".
     
  5. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #5
    Thanks for this, this is definitely UNchecked already.

    the problem I'm having is,

    i want their to be a password when I'm away from from the computer, so when screensaver starts, when i return, a password is required.

    but at the same time, when i turn the comp on from being shutdown all night, i want it to load straight into my user ...

    is this possible do you think ?

    many thanks in advance
     
  6. Bruno09, Dec 29, 2014
    Last edited: Dec 29, 2014

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    I just checked again that with this setup :

    UNchecked : "Disable automatic login", and :

    Checked : "Require password" = Immediatly after sleep or screen saver begins"

    the behavior is exactly what you are after.

    ---> check "Disable automatic login", then uncheck it so that you will have to enter your password.


    Other way : System Preferences / Users and groups / Options : "Automatic login", select your username.
     
  7. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #7

    hi, sorry for late reply, i had to test what wed discussed - but alas, no joy :(

    i have all the settings correctly, so i took a snap shot of my comp when it wakes from a scheduled startup ...
     

    Attached Files:

  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    I have just tested again and it does work for me, even when it wakes from a scheduled startup.

    I am on Mavericks 10.9.5

    What OS are you running ?
     
  9. brentmore macrumors 6502

    brentmore

    Joined:
    Jul 19, 2002
    Location:
    New York
    #9
    Is FV enabled? If so, it will prevent you from automatic logins.
     
  10. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #10
    what's the point of this setup, as it would offer zero security anyway? just disable all passwords, would be the same.
     
  11. stuartrozier thread starter macrumors regular

    Joined:
    Nov 12, 2011
    #11
    just stops prying eyes when i leave the room -

    but would like instant access when i start up from boot.
     
  12. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #12
    So a hard reset (on-off button) will reboot your Mac with NO password, useless! Just use the password on boot option and just type it. Best option.

    Cheers
     

Share This Page