Password saved in AutoFill (Settings:Safari) but not appearing in web page login box

Discussion in 'iPhone' started by TH55, Oct 8, 2014.

  1. TH55 macrumors 68030

    Joined:
    Nov 5, 2011
    #1
    When logging into a website it initially prompted me with the "save password" pop up which I clicked. The username and password are saved in AutoFill under Safari Settings but when I go to the website only the username appears. Before in iOS 7 it showed both for this same website, now I have to type it in every time. Why is it doing this?
     
  2. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #2
    I sometimes have this happen on certain websites too.

    Once I click on the login box though I press the "autofill" button right above the keyboard and it does what it's supposed to.
     
  3. TH55 thread starter macrumors 68030

    Joined:
    Nov 5, 2011
    #3
    But why did it always appear along w the username before?
     
  4. TH55 thread starter macrumors 68030

    Joined:
    Nov 5, 2011
    #4
    When did they switch to this "auto fill" button instead of just filling the password in automatically?
     
  5. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #5
    Not sure why certain websites do this, wish I could give you a better answer :(

    For most websites, for me probably around 90-95%, my keychain username/password automatically fills... but every now and then a certain website wants to be a troublemaker and requires me to press the autofill button.

    If anything I would say it's an issue with the security settings of that specific website, not iCloud Keychain (since it almost always works perfect for me).
     
  6. TH55 thread starter macrumors 68030

    Joined:
    Nov 5, 2011
    #6
    It has to be iOS, it worked fine on iOS 7.
     
  7. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #7
    Well, personally I'm on iOS 7 and still have always had that issue with certain websites.

    Not saying iOS 8 didn't screw it up for you, just that there's always been a random website that does it for me even on iOS 7.
     
  8. TH55 thread starter macrumors 68030

    Joined:
    Nov 5, 2011
    #8
    Oh ok, ya this website used to work fine.
     

Share This Page