PB 4 - Parallels hijacked the .dmg default app

Discussion in 'OS X El Capitan (10.11)' started by Scary Spice, Aug 5, 2015.

  1. Scary Spice macrumors regular

    Scary Spice

    Joined:
    Jul 31, 2015
    Location:
    British Columbia
    #1
    After a clean install, (PB 1, updates 2, 3, 4), then installing Parallels 10 (latest version), dmg files are now set to "Open with:" Parallels Desktop (default) and there is no option to set it back to Finder or whatever replaces DiskImageMounter in 10.11 .

    Any suggestions how to get dmg's to open in Finder again?
     
  2. jruschme macrumors 6502

    jruschme

    Joined:
    Dec 20, 2011
    Location:
    Brick, NJ
    #2
    Right click on a disk image in Finder and select Get Info. In the "Open with" section, you should be able to change the default application.
     
  3. Scary Spice, Aug 5, 2015
    Last edited: Aug 5, 2015

    Scary Spice thread starter macrumors regular

    Scary Spice

    Joined:
    Jul 31, 2015
    Location:
    British Columbia
    #3

    TO re-iterate, when I am trying revert the dmg file association BACK to Finder, I go to Get Info via right clicking on the file in Finder. Get Info reports that dmg files are now set to "Open with:" Parallels Desktop (default) and there is no option to set it back to Finder or whatever replaces DiskImageMounter in 10.11 .

    In 10.11 what is the default application for opening dmg's? A spotlight search shows no presence of DiskImageMounter.
     
  4. jruschme macrumors 6502

    jruschme

    Joined:
    Dec 20, 2011
    Location:
    Brick, NJ
    #4
    On my system (also running 10.11 DP6), the "Open with:" section has a dropdown menu. It is initially set to the default app. If you change the value it enables an option to make that the default for all files of the type. (See screenshot attached)

    FYI, DiskImageMounter should be located at /System/Library/CoreServices/DiskImageMounter.app
     

    Attached Files:

Share This Page