PB charging problem...

Discussion in 'Mac Basics and Help' started by mtbikex, Dec 26, 2005.

  1. mtbikex macrumors newbie

    Jul 9, 2005

    Last night my 17" powerbook's battery drained to 0% (it was plugged in all of yesterday and last night) while it was plugged in and now it will not charge at all. It still gets power from the adapter (i'm using it now), but it will not charge. It just says "(Calculating...)" and won't progress from there. There isn't anything that I can see physically wrong with the adapter, and it gives me the orange light which I've always asumed meant that it was charging. I ran the coconutBattery utility and it told me that the charge is 11mAh/4888mAh. It also detects that the charger is connected, but it says that the battery is not charging. The Mac is only 6 months old, so I don't think the battery has lost a significant amount of life.

    Any ideas?

  2. mklos macrumors 68000


    Dec 4, 2002
    My house!
    I would take it to Apple and see what they can do. Theh battery may have failed. Better to do it now, while its under warranty then wait until its out of warranty and then everything comes out of your pocket.
  3. OutThere macrumors 603


    Dec 19, 2002
  4. barrysfarm macrumors regular

    Nov 1, 2005
    The exact same thing happened to me like two months ago. I posted a thread on it here and it quickly became a "everybody brag about how good their battery life is" thread. No solution came up. I tried reseting the PRAM and even reinstalling the OS but nothing worked. People suggested that I needed to purchase a new battery. I still haven't bought a new battery, but if I ever get any money or a job then I'll probably buy one.

Share This Page