PB G4, SuperDrive not reading disks

Discussion in 'Mac Basics and Help' started by Furrybeagle, Nov 19, 2007.

  1. Furrybeagle macrumors 6502

    Furrybeagle

    Joined:
    Sep 13, 2004
    #1
    Seems I am having a problem with my SuperDrive. Whenever I insert a DVD, CD, whatever, Mac OS X (10.5.1) pops up an error that says, “Disk Insertion: The disk you inserted was not readable by this computer.” It gives the option of Ignore or Eject (if you leave it it just ejects for you). I also tried my system disk… it said it was a blank DVD. I figured it may be an OS issue, but restarting the computer with the system DVD in the drive doesn’t boot to the DVD, and instead OS X just spits it out once it has loaded. I reset the PRAM and tried booting with option held down to select a boot device, but the drive didn’t appear. System Profiler is giving incorrect information about the drive:

    LATSHITADVD-R TJ,825D:

    Model: LATSHITADVD-R TJ,825D
    Revision: FAND
    Serial Number:
    Detachable Drive: No
    Protocol: ATAPI
    Unit Number: 0
    Socket Type: Internal
    Low Power Polling: No


    I know the drive is a Matshita, not a “Latshita”, and I’m pretty sure it used to have a serial number and a revision *number*. System Profiler says it can burn discs, Disk Utility says it can’t. Disk Utility also calls it a “M@TRHHT@ DVD,R UJ-834E”… obviously not right. I read that it may be an issue with the ATA connector (since it is throwing up incorrect information).

    Of other note, System Profiler reports sizes when disks are inserted (my 10.4.0 Tiger DVD is reported as 2.51 GB, if anyone wants to confirm). I tried two drive cleaning CDs, but they didn’t seem to do anything (in fact, the first one caused Mac OS X to completely freeze). The computer is a Jan 2005 rev. PowerBook G4 15”, 1.67 GHz, 1 GB RAM (one Crucial DIMM, one Apple DIMM), 128 MB VRAM, 80 GB (Hitachi) HDD. Clean install of Leopard.

    I’m guessing my only option is to bring it in to the Genius Bar… but if anyone has any ideas that would be greatly appreciated.
     
  2. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    I'm guessing that this is a Titanium powerbook because of the 825 number on the Matshita drive. That's an old superdrive. They are very easy to replace on the Tibook. Buy a new one. Install yourself. Toss this old one. Or, I have a combo drive that would work for you for 22 bucks shipped (does not burn dvds, only plays them and cd burner.)
     
  3. admiraldennis macrumors regular

    Joined:
    Aug 19, 2002
    Location:
    Boston, MA
    #3
    Either your optical drive is dead (most likely) or it's cable has somehow come loose.

    Indeed, if you have a titanium, I'd recommend trying to replace it yourself.
     
  4. Furrybeagle thread starter macrumors 6502

    Furrybeagle

    Joined:
    Sep 13, 2004
    #4
    It’s an Aluminum PowerBook, and the drive is a DVD±RW single layer drive… maybe the model number is reporting wrong? It’s under warranty but I can’t send it in for repair right now.
     

Share This Page