PB G4 will not recognize USB printer

Discussion in 'Mac Accessories' started by I am Bebop, Aug 27, 2009.

  1. I am Bebop macrumors newbie

    Joined:
    Aug 27, 2009
    #1
    Hi,

    I have a very simple problem:

    I have a Canon PIXMA iP4200, and I want to use it to print things. I have it plugged in to my PowerBook G4 via USB, but it does not show up. When I "Add Printer" (via Print and Fax preferences, or from any print dialog), I cannot find any option for USB printers... (it is not on the Canon IJ Network, it is not a Bluetooth printer, etc. it is plugged directly into the computer)

    I know for a fact that I have the driver, and that the printer works, because I have printed using this printer via a network, back before my Mac Mini (into which the printer has always been plugged) died. I have also verified that the USB cable and my USB ports are in working order. And yes, the printer is turned on.

    Am I overlooking something easy? With the Mini dying, and the PB not printing, I am not in a very :apple:-friendly mood. I hope it is a simple user error.

    Thanks for looking.

    __________________
    PowerMac G4 Al 1 GHz (Mac OS 10.5.8)
     
  2. Thiol macrumors 6502a

    Thiol

    Joined:
    Jan 26, 2008
    #2
  3. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #3
    I had a similar problem with a Epson Stylus CX3200 and a G4 PB. Trouble is I don't remember how I fixed it.

    Try downloading a new driver and deleting the old driver.
     
  4. I am Bebop thread starter macrumors newbie

    Joined:
    Aug 27, 2009
    #4
    still not finding that printer...

    Thiol. Unfortunately, I am running Leopard, not Tiger, and that kb article is sadly not applicable to Leopard (I had actually already seen it).
    jodelli. Unfortunately, I have already tried reïnstalling the driver to no avail.

    Thanks to both for your responses, though!
     
  5. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #5
    I wish I could remember what the glitch was in my case. It was something simple.
     
  6. I am Bebop thread starter macrumors newbie

    Joined:
    Aug 27, 2009
  7. jodelli macrumors 65816

    jodelli

    Joined:
    Jan 6, 2008
    Location:
    Windsor, ON, Canada
    #7
    I do remember, after having been stymied earlier, setting up the printer as if I had just bought it new from the store, erasing old traces on the drive and following the step by step of the setup cheat sheet.

    Good luck!
     
  8. I am Bebop thread starter macrumors newbie

    Joined:
    Aug 27, 2009
    #8
    setup cheat sheet...

    Ah. Well that does sound like a good idea. I don't think I ever had a setup cheat sheet, but I suppose I could try to root around and delete printer preference files and such... maybe that would have some effect.

    I will keep you posted.
     

Share This Page