PB screenfading

Discussion in 'Macintosh Computers' started by Cuckoo, Feb 21, 2005.

  1. Cuckoo macrumors 6502

    May 2, 2003
    The Netherlands - Utrecht
    Hi All,

    Since about two days i have this weird problem with my 15" PB (1.25Ghz-512RAM all stock). It seems that, while working, the screen fades in .. and fades out, not much, but enough to notice, just like it were adjusting to a more dark surrounding -but that is not the case-

    Can anybody suggest anything? It's not really an issue, but it does annoy..

    Any help is appriciated.

  2. varmit macrumors 68000


    Aug 5, 2003
    Are you working in a dim light? This is the powerbook trying to ajust to the light around it, to save power. If you walk into a dark room, it will dim the backlight to the screen and turn on the backlight to the keyboard (if yours has it). Try putting your hands over both speakers to block the light from going into where the sensors are at for a few seconds, the screen will fade out, then remove your hands, and it shouldl fade back in. You can turn it off I believe, not sure where though. I'll get back to you on that.

    EDIT: Its under Display in the System Preferences. Its at the bottom of Displays area (Picture attached).

    Attached Files:

  3. JzzTrump22 macrumors 65816

    Apr 13, 2004
    New York
    It's the backlight. You just have to adjust it. Try to keep the light in the room constant if you don't want it to dip in and out of brightness.
  4. jim. macrumors 6502

    Dec 22, 2004
    C-ville, VA
    In addition, if you are running 10.3.8 there seems to be a common issue with hypersensitive brightness adjusting in powerbooks. I've found two suggested fixes. One involves simply disabling the automatic adjustment as mentioned above, and the other involves using Pacifist to install a previous version of the brightness control driver.

    I've just disabled the automatic adjustments for now as I'm rarely, if ever, in dim conditions.

  5. andiwm2003 macrumors 601


    Mar 29, 2004
    Boston, MA
    same here. since 10.3.8 the brightness changed almost randomly. seems it even reacted to the shadow of my hand while typing. it was much worse in artificial light compared to real daylight. probably it picks up the 60 Hz from lightbulbs.

    disabling the automatic brightnes adjusting fixed it. its much better to adjust the brightnes with f1-f2 anyway.

  6. gdl96 macrumors newbie

    Jun 28, 2004
    new jersey
    I'm having that problem too. I thought it might be some dust that got in through the speakers and messing with the light sensor since my dorm room is really dusty. I guess it's just the software.
  7. Cuckoo thread starter macrumors 6502

    May 2, 2003
    The Netherlands - Utrecht
    Thanks all, that put my mind at easy... i was afraid there was some hardware failure comming around the corner....

Share This Page